Texture Adjustment Mask problem

Using a saved mask, when I try to paste it in the Texture adjustment, it does nothing - just a black rectangle shows. The mask works properly in all other adjustments. However, this is an unusual case. These are the steps I did:

  1. Create montage using image layer adjustment twice. Save as tiff
  2. Use ReMask 5 plug-in to mask out what I don’t want. Use a transparent background.
  3. Refine image in PS6. and then make background white. Keep as tif. Close out of PS6.
  4. Open Studio and open image. Use Basic adjustment and create mask of image without white background. Copy the mask
  5. Use a couple of other adjustments with the pasted mask. Save as a tiff and also as a tsp.
  6. Open a texture adjustment on the tsp, and try to paste the mask. Get only a black rectangle (or white if I click on invert). In either case, no mask. Textures either do nothing (black rectangle) or cover everything (white rectangle).
  7. Try with the tiff. Same exact thing.
  8. Close texture adjustment. Previous adjustment shows along with mask. Click on Global mask. Paste mask there. Then copy it from there.
  9. Open texture adjustment. When it opens, the default texture appears properly with proper mask attributes, even though I have not even tried to paste the mask. From that point on I can use the texture adjustment normally.

Again, this does not happen with any other adjustment (at least the ones I tried (didn’t try every one)).

Is there something I’m doing wrong or is it a problem with the Texture Adjustment?


I can’t replicate that because I use the mask from each of the types of image.

The only thing I can suggest is that you need to copy the mask from the opened image that you are working on … eg from the TIF to TIF or the TSP to TSP as you cannot copy masks between individual images.

I know that my post was complicated, but I DID copy the mask from the opened image I was working on. It worked fine for all adjustments except the Texture Adjustment.

I went back and replicated it on the same image that I had saved originally, and it does exactly the same thing. Maybe since I found the workaround it won’t be a problem. But I really think copy/paste masks should work the same on the Texture Adjustment that it does on the other adjustments.


OK, the best to do then is raise a support request at the Need Help? link on the page above.