Studio V1.1.9 Update Does Not Launch

Updated V1.1.8 to V1.1.9 on my iMac and now Topaz Studio does not launch.

Same issue here. Tried installing through an older installer, and it still doesn’t launch, nor does dumping prefs help.

We’re working on it now. When we get the fix uploaded, you’ll need to download and install again from the Studio Download page. I’ll update this thread when we get it uploaded for you to give the update another shot. Sorry for the inconvenience, we should have it corrected soon.

Problem has been addressed, and build is uploaded to the server. Please head to the Studio Download page, grab the online installer, and reinstall:

Sorry for the inconvenience!

1 Like

Joe, is this a download we should all make. Miy 1.1.9 version has worked perfectly from the get go.

It sounds like you updated after we fixed the problem :slight_smile: Also, it only impacted Mac users.

I too am a Mac user…I can report that last night while working on an image TS just stalled. It did not shut down (crash) it just would not register any changes that I made. I saved the image. And then reopened it and we were back in business. I have no idea what was going on and I doubt I can replicate it.

I am running version 1.1.9 on OSX 10.12.5 on 13 in MacBook Pro mid 2012 with 16GB of installed memory.