Studio still not working well with Lightroom

Edited image via LR direct Topaz Studio 1.0.9 and back. Finished editing in Studio, clicked Save to return to LR and LR was unable to read the file initially. The screen continued to flash for about 30 seconds or so then the image returned to the screen. I’m using a Retina 5K (3.3Ghz Core i5) iMac OS 10.12.6. LR really struggles with reading files when I don’t start out in PSCC on the way to Studio. Is this being worked on?

Tiffs out of Studio will not render in Lightroom if you go directly to Studio from Lightroom and back. But if you use Photoshop as an intermediary then they are fine. Alternatively, use jpgs.

This seems to be a Mac problem and has been reported some time ago but no sign yet of a fix.

Thanks, Ray I reported this a few months ago in version 1.0.5 or 1.06 and
thought I would give it another try. So much for perseverance. I¹ll go back
to PS and keep praying.
Warren

forumreplies+81bbf116455cdb08271518d54e3f182b@topazlabs.com

This must be a Mac issue as on Windows mine render fine.

The strange thing is that my image eventually DID render after 30 seconds of struggle. When I tried this in v1.0.5/6 LR failed to render altogether. Sounds like some progress has been made - perhaps.
Warren

I am having this same issue on Windows 7. From Lightroom to Topaz Studio via plug in link. After editing, and click save, no image appears in Lightroom. It is within the folder on the hard drive and I have to synchronize the folder for the image to appear.

What is the status on this issue?

Topaz Studio crashes every time I go from LR6, so I tried going through Photoshop CS5. Still the same problem. When I hit save, I get the “Processing”, then just a black screen, then have to go to Task Manager to shut TS down. TS has lots of neat features but doesn’t do any good when I can’t save my photos. Just trying the free version for now, but no need in upgrading if I can’t use the program. I did submit a ticket.

Please specify details of your hardware … i.e. RAM, PC & OS, GPU etc and what version of Topaz Studio you are using.

Computer info: 16G RAM, Windows 7, Graphics Card: AMD Radeon HD 6450, and AMD Quad Core Processor, 500W Power Supply. I think that’s all the info you requested but let me know if I missed something.

Laurie Schaerer
Please visit my websites:
www.laurieschaerer.offtoneverland.com
www.lautondesigns.etsy.com