Studio as a standalone

I have Studio installed; downloaded it when it first came out. After trying it, as a standalone, I was underwhelmed and stuck with my PS plug-ins. When Detail for Studio came out and I started reading between all of the lines, I figured that I’d better try Studio again. After the first update download, nothing worked: couldn’t open the program from PS, from right-cliicking on a photo file; from the standalone icon on the desktop. I contacted Topaz, tried all of the trouble shooting, updated the GPU drivers, forwarded all of the requested info and files to Topaz. The only feedback I received from my “Customer Happiness” person was a ticket number, and after 5 days, a note telling me that since I had not contacted them again, they assumed that the problem was fixed and I had two days to tell them it was not fixed. I told them. I guess I’m supposed to try to open the program hourly, until something changes - I think that’s the definition of insanity. Anyway, I found version 1.3.4 and installed it. Studio now opens in PS CC 2017, but will not respond to being called from any other source - I do not use Lightroom.

My real current question: Is Studio supposed to work as a standalone program from the desktop icon that it installs?

benasaj

Studio does indeed run as a standalone and has always done so. Can you say what source you are trying to call Studio from and it doesn’t respond.

Nowhere does it say you are supposed to do that.

And then provide a little with information about the type of PC you are using and confirming that you do indeed meet the technical specifications listed here:

I did verify that I exceed all requirements. I even sent in the system diagnostic file that was suggested. I am running the latest version of Win 10 and updated my GPU drivers from the Nvidia site. Topaz has all of my symptoms and system info.

A partial copy of my correspondence:
"10/02 response:
My request has been pending for 5 days because no Customer Happiness Specialist has responded to me about a fix.

So I now tried to open Studio and was told that an update was available and I installed it (ver. 1.3.3). I called Studio from PSCC and after telling me that it was opening, it never did. I called Studio from a “tiff” file and it opened in the icon on the task bar, but not the main screen. By right-clicking on that miniature picture in the task bar and picking “maximize” from the popup menu, the app opened full screen. I resized it slightly and worked on the “tiff” and then closed the app. I called it up again from another “tiff” file and all I got in the icon miniature on the task bar was “Topaz Studio (not responding)”. I deleted the app from my computer, rebooted my computer, downloaded a fresh copy of 1.3.3 and installed it. Now when I select the desktop “shortcut” all I get is the icon miniature on the task bar with “Topaz Studio (not responding)”. The program will not open. That’s the same response if I call Studio directly from a “tiff” file.

HOWEVER, the good news is that Studio now works properly when called from PSCC (Filters->Topaz->Topaz Studio). Unfortunately, I can also pick any one of my Topaz apps directly as well and Studio serves no purpose. It should eliminate the need for PS … I thought.

Al Benas
Unhappy Customer

Sent from Mail for Windows 10

From: Topaz Studio
Sent: Monday, October 2, 2017 11:02 AM
To: Albenasphotography
Subject: [Topaz Labs] Pending: Topaz Studio

Please type your reply above this line only.

Hi! This is just to remind you that your request (#126036) has been pending for more than 5 days and that we’re still here to help. We’ll automatically mark your issue as “solved” in 2 more days, but feel free to reply to this email at any time to reopen the issue.
Rose Bohre (Topaz Studio)
Sep 27, 9:34 AM CDT
Hi Albena,

Thank you for contacting Topaz Labs!

We are currently working on fixing this issue. Please be on the lookout for future updates and bug fixes.

Thanks!
Kind Regards,
Rose Bohre
Customer Happiness Specialist
M-F: 8:30am-5:30pm CST

Thank you for trying Topaz Studio!"

I called Topaz Studio from a “tiff” photo file in Nikon View NX2. It is set up to open the file in any designated program (I used Topaz Studio.exe). I also called Topaz Studio from the desktop icon that it installed. In both cases the program opens (as shown in “Task Manager”) but stalls out (with the “Not Responding” message), and never gets past a blank white screen. I just tried calling the program from the “Start” menu with the same result. As I said above, it will run properly from PSCC 2017 on the open “Tiff” file. Also, FWIW, Topaz Studio is on the local C-drive and all photo files are on an external G-drive. Any ideas are welcome.

Then please post your system specs here … I have asked you to specify the type of PC you are using and its specifications. As it is a Windows PC please type DxDiag in the search box, run it, then save the output to a text file and upload it by attaching it to this thread.

Also I don’t understand your terminology where you say you “Called Topaz Studio from a Tiff file or from the Icon”. Try double clicking on the Icon and then choose file open and open your image.

The blank white screen usually indicates that there is not enough GPU power or you have Dual-GPU’s and you are using the low power integrated GPU instead of the high performance GPU. All will be revealed when you attach the output from DxDiag.

Did you reply to the email to keep it open?

I use Studio as a plugin from PhotoLine and it responds and works properly, so it does respond to being called by at least that application.

As I previously stated, in my own terminology, I sent the DxDiag file to Topaz but I shall include it here as well. I assumed that when I communicated with Topaz, as they instructed on their support page, that the information goes to someone for analysis, and that I would receive some sort of reply. I never ask for help without researching everything that I can find, trying every idea or method that I can come up with. Usually, an “Ah, hah!” moment hits me and I solve the problem. In this case everything that I have done has resulted in inconsistent results and I’m at a loss.

I read a previous post on the forum, prior to asking for help, about using the high performance GPU. I Then went into the Nvidia dashboard and set that as my default on all of my graphics programs, as far as I know.

When I said “called from” I meant:

  1. Double clicking on the installed shortcut icon on my desktop.
  2. Double clicking on the program listing in the “Start” menu.
  3. Right clicking on the photo file “Tiff” listing in Windows Explorer and using “Open with”.
    or
  4. Using the “Open with” option in the Nikon View NX2 or View NX-i menu that the user can customize.

When I first installed Studio, it worked fine, but not since I installed ver. 1.3.3. I’ve found that 90+ % of the time, it’s user error, but I’m at a loss.
DxDiag.txt (104.7 KB)

My suspicion is that you are using the Intel® HD Graphics 530 (128MB RAM) for running Topaz Studio and the easiest way to test for this is to go to the Studio icon on your desktop, right-click on it and select Run with graphics processor, then High-performance NVIDIA processor.

If that solves your problem you need to assign the NVIDIA to Studio and to any other application that calls Studio, such as PPS and LR.

I would suggest you either set your default GPU as the NVIDIA GPU by following these instructions, note that products that behave properly and don’t need the NVIDIA will select the integrated GPU, products such as word processors etc. Here are the instructions and a screen shot of the NVIDIA Control Panel:

Open the Control Panel, either by typing Control Panel in the Cortana box where it says “Ask me anything” or the same box which will have “Search Windows” if Cortana isn’t activated

  • Select Hardware & Sound
  • Select NVIDIA Control Panel
  • In the left pane, make sure Manage 3D Settings is selected
  • In the Right Pane select High-performance NVIDIA Processor from the “Preferred graphics processor:” drop-down list
  • Click the Apply button in the bottom right hand corner.
  • Then exit from the control panel.

Studio will run OK now as you have 2 GPU’s on your system of which the Intel HD Graphics is the default and it has insufficient memory to run graphics intensive applications that the NVIDIA, your other GPU, can with 4GB of memory. This selection will also improve the performance of other applications like Texture Effects, Impression, Photoshop or any RAW processors like Lightroom that you may have installed.

If you want to use dual GPU’s, as I do, you will need to select the Program Settings tab and assign High-performance NVIDIA Processor from the “Preferred graphics processor:” drop-down list for each application you want too use the processor.

Finally, as this is a user to user forum, please tone down your posts in order to get help.

NOTE: All other applications that you use to call Studio must also use the NVIDIA processor so they will need to be assigned to use the NVIDIA GPU.

I followed your instructions. My Nvidia high performance driver is now set as my default, and I added every graphics program to the “use” list. All of my standalone graphics programs work fine except Studio. It still refuses to complete opening (just the white screen in the taskbar icon + Not Rsponding), except from the filter menu in PSCC 2017 - works fine from there.

I don’t know if it has any significance, but I mentioned in my email to Topaz that I am running a dual monitor system. The laptop is primary and the large external monitor is secondary - both are 4K. My various programs pick where they want to open. I have also attached a screen shot from Task Manager showing the situation of Studio:

I think you need to submit another Technical Support ticket as it may well be a problem with your dual monitors because when you use it from PS CC as a plugin it will open on the monitor PS CC is using.

And, as I believe they are busy, if you get a message " We’ll automatically mark your issue as “solved” in 2 more days, but feel free to reply to this email at any time to reopen the issue. " simply reply to the email to keep it open.

In the meantime see this article for setting up dual displays. I would choose the duplicate which means that if it is connected it displays on both monitors.

http://www.eizoglobal.com/library/basics/windows-10-multi-display-function/index.html

I just tried opening some other older Topaz standalone apps that I had on my desktop. I had never used them before since is was more convenient to open them from PS. They opened but crashed when I selected a file to work on. I then tried turning off my external monitor, to no avail. I will open another support ticket. It has always been my luck to find really weird problems in many different software programs … horrible karma.

Thanks for trying.

We seem to be having the same issue. New user to the product here. We downloaded it and installed, and it seemed. OK. Then later when trying to open the software again, nothing happens. The icon shows up in the tray at the bottom of the screen, but nothing happens. If we put the cursor on the icon, the thumbnail is a blank white square with “not responding” at the top.

Please help by supplying a little information such as your PC specifications, how it is being used etc.

Please raise a Technical Support request at the Submit a Ticket link above after making sure of the following points noteing that the application has specific high-end technical requirements:

  • You meet the technical requirements listed in link in the second post above.
  • Your GPU drivers are up to date, from the GPU manufacturers website.
  • If you do and you have a dual GPU system you are using the high-performance GPU not the integrated GPU.
  • If you have a Dual-GPU system and it is a NVIDIA there are instructions to follow above to allocate the high-performance GPU to Studio.

Same problem, new wrinkle. I opened a file to work on in PSCC; called filter -> Topaz Studio Detail. When it opened, I checked Help -> check for updates. It reported that there was an update available, but to get it I had to use the standalone app. That is my entire problem - can’t get the standalone to open (Catch 22). I have installer version 1.3.4 on my machine, Is there a newer version? If so, how do I get it? If not, what is the filter app, when called from PSCC, looking for (it shows ver. 1.3.4 in “Help -> About”)?

Topaz has not acknowledged my service ticket request as yet.

First you need to uninstall the current version and then download and run the installer from http://web.topazlabs.com/

Make sure that you only have one copy installed on your PC, i.e. do not install to other locations and yes you cannot update while PS CC is open or from the Plugin … this is for ALL plugins, not just Topaz.

I wasn’t criticizing Topaz; I just didn’t think about how to get around the problem by uninstalling. That worked perfectly. Topaz also updated their web site in the last couple of hours to reflect ver. 1.4.2 instead of 1.3.4.

I installed the new version and Studio opens in PSCC, but still not from the Standalone. We’ll just wait.

It sounds like the problem you have is that the application is opening offscreen, which freezes the process, and prevents you from using Studio. This has been solved in the 1.4.4. update. Please update to the latest version, and let me know if it’s working.

Sorry it took so long to respond; I’m still learning my way around the forums - making it more difficult than it is.

I saw the new version 1.4.4, downloaded it and installed it. Initially no joy. Then I saw your comment and tried again. I called Studio from the Standalone desktop icon. When nothing happened, I right-clicked on the toolbar icon to close it. There was no “not responding” message, but “Maximize” was lit. When I clicked on it, Topaz Studio opened on my primary screen and has been behaving well since then. However, now when I open Studio -> Detail from PSCC, it doesn’t show on screen until I go through the “Maximize” routine - used to open automatically on screen from PSCC before. It’s not totally fixed, but at least now I can get directly to Studio from any stored tiff photo file without going through PSCC, and that’s great. I’m happy.

I’m not able to recreate what you describe. The application opens on screen for me, each time I launch it as either a standalone or a plugin. What happens if you simply click the icon in your taskbar, rather than using the Maximize option?

If I just click on the toolbar icon, the program apparently (I’m seeing
some ghosts on screen) tries to open behind PSCC on my secondary (extended
desktop) monitor. The PSCC screen goes blank and I see very faint edges of
outlines of the Studio screen. At that point, I have to use Task Manager to
close out of Studio and PSCC, which is locked once Studio tries to open. If
I use Maximize to open the Topaz “filter” it opens OK on my primary screen
(same as where it opens from the Standalone). In case you are not aware of
my setup, I have an Asus laptop with a 4k screen set as my primary screen
and a Samsung 4k large monitor as my secondary or extended desktop screen.

If I open my original Topaz B&W filter from PSCC->Filter->Topaz Labs->B&W,
it behaves perfectly - PSCC on the monitor, Topaz B&W dialog screen on the
laptop (the same way Studio did prior to ver 1.4.4). So the Standalone
problem was fixed, but the PSCC option was broken. But I like this
condition better; at least I have a usable workaround.

Al Benas
albenasphotography.com