Studio 2 v2.0.11 yet another bug report!

Two new new issues have been introduced with the latest updates that I have encountered today in just 5 minutes of use (so far):

  1. Plugin operation/open with from Bridge CC is broken. Need to open Studio separately and open files by using the Studio open. “Open with…” in Bridge CC no longer transfers and opens image in Studio. Worked just fine in before update to 2.0.11. Really upsets what was a smooth workflow!

  2. Preferences menu item is no longer available! It is grayed out!

System Mac OS Mojave 10.14.6.

How does one roll back to a previous version of Studio2 that actually works properly?

1 Like

I have seen posted that some Mac users have used Time-Machine to roll back to an earlier version.

I’m a Win-10 user, so these points only apply in that context:

~ Preferences working as normal
~ Calling DeNoiseAI actually opens SharpenAI (support case open).* someone really dropped the ball on that one*

From what I have observed, there seem to be lots of (new) issues with inter-operation between Adobe products and TS2.

Actually, it looks like inter application communication is just plain broken with 2.0.11 as using “Open with…” or “Export to…” opens Studio but never ever loads the image.


Sorry, but I am not using Lightroom.

The issue is occurring if I do, i.e. “Open with…” in Bridge CC or “Export to…” with DxO PhotoLab or even “Open with…” from Finder. None of these conditions have anything to do with Lightroom and they all worked as expected before 2.0.11!

Looks like it may be broken on the Mac side, but appears to still be working on Win. I can call TS2 from Affinity Photo or ACDSee and it still works. Have you opened a support case?


It’s broken on Windows also, Lightroom etc. Plugins, as you mentioned still work.

Also confirm plugin problems. On prior version was able to open from Apple Photos via the ‘External Editors’ plugin and it was very slick. It now opens TS2 but no image is there.

I am running Mac OS10.14.6 Mojave and the update from version 2.10 was kludgy and would not complete the installation. I rebooted my system. Started Topaz 2 once again and then the installation apparently worked despite an earlier message that said the installation was corrupted. . As a standalone TS2 version 2.0.11 seems to work(See note 2) but I am unable to invoke TS2 from the Photo Edit it in drop down. I could do it in earlier versions from LR? I can not install it as Plugin either as it is greyed out when I try to add it.
2. Loaded an image directly into TS2 invoked a Look, which I did not like when I saw it on the image and could not Undo the look.
3. Brought up the Text tool to enter my watermark. Change my mind and the entire image was surrounded by the Text Edit Bar.
4. I am finding it working significantly slower than earlier versions on the same configuration.
What happened between 2.0.11 and prior versions?

Same macOS version as you have. Yes, it seems that anything that uses the “Open with…” mechanism whatever any particular app may call it, including Finder, is broke. TS2 v2.0.11 opens but never loads the image. I haven’t seen #2 but I have only been working with my own custom “Looks” which may or may not be relevant. I haven’t noticed much difference in speed.

FWIW, during the update process, I saw a QT install, which is cross platform application framework they are using. Perhaps there was an update to it that has its own bugs. I say that as the issues I am seeing seem to be fundamental application issues, like the “Open with…”, rather than the functions specific to what TS2 does in terms of image functions.

1 Like

Thank you Ellwood for your response.

Yes, I do understand that the link to invoke TS2 and the in applications “burps” are not techinically connected. I think like many users of TS2 I am frustrated that this version seems to be so buggy. And, as Beta Tester I wish they would have us test a new public version before they launch it so as to avoid the the “bad press” and bad feelings it is causing.

When I am beta testing I can expect it to go south or have hiccups. But, I don’t think it is good business to have that same experience when it is a public version.

Have a good weekend.


It seems more and more like Topaz, like many other companies, have had marketing and bean counters take control from the developers and push them into releasing things before they are really ready.

But then that is just my opinion.


Hi Stephen, unless you Apply the Look after selecting it there is nothing to undo. Just click on another Look and it will change

1 Like

Thanks Don, as I could not see the effect of the look while I was rolling over the looks I did hit Apply and could not revert back to the original with the Undo arrow or Control Z. I just shut TS2 down and did not save the changes and had my original back.

1 Like

cntl+shift+r - or the Mac equivalent.


I am not sure about Mac’s but I have found that Edit-> Undo works.

As others have noted, I uninstalled TS2 and reinstalled from ‘My Products’ page. Version 2.0.10 was installed and is working properly: will leave well alone until Topaz advise that upgrade is woking well in all aspects.

Did the same thing and it seems all is as it was before v2.0.11. What ever was done between 2.0.10 and 2.0.11 really threw a monkey wrench into things. From now on, I will make sure I do a system snapshot just before applying any future updates and test the new update thoroughly before doing any real work so I don’t loose anything rolling back. Mmmm, sounds almost like a beta tester procedure.


I found an interim fix to my crashes (always while scrolling through 'Looks"), and failed interfaces between Lightroom and TS2 (may well be the same issue with Bridge)… Verion 2.0.10 is still the downloadable version on the Topaz Labs site. Sign n to your account, re-downlaod 2.0.10 and install – it will (when prompted) uninstall the more recent updated version that is causing the problems. Voila. Everything works. No crashes.

Thank you Paul…I will give it a go.

1 Like

It appears that the new v2.0.12 release I installed today solved the two issues I posted. Preference menu item is back and the “open with” mechanism is fixed.

1 Like