Studio 2.2.0 won’t load

Went to update Studio 2 to 2.2.0. It deletes the previous version and installs the latest. However the latest version will not boot. Opened a ticket, did what they suggested but still will not boot and my old version is gone so no Studio 2 at all.
It’s been 3 days now and no response from Topaz. I paid over $400 for this software and now I have nothing and no support.

Hi, can you supply a little more information please … specifically:

  • Your OS and GPU along with RAM, dedicated vRAM and driver version of the GPU.
  • Any error messages or OS events.

When you installed the update did it run after the update?

Are you trying to run as a standalone or as a plug-in, and if a plug-in from which host?

She just said that it didn’t run. Same thing happened to me. I raisedasupport ticket and got a response that said “ how can I help you” and after I responded , nothing !
Was able to get back to 2.1 through system restore

Hi,
My OS is Win 10 home (latest with all updates) and 16 gig RAM, My GPU is NVDIA GTX 1060 Diver version 26.21.14.3190 dated 04 Sept 2019 and has 16 gig dedicated video RAM.
No error messages after update.
Studio 2.0 was running fine and I clicked on the update window when presented. The update proceeded with the first message indicating that it would remove Studio Version 2.0. Update proceeded. I checked relative folders to see if the new files were present. They were.
After update finished it asked if I wanted to launch program and I did. After waiting at least 5 minutes nothing came up on screen. I rebooted machine and tried to launch again. Still nothing. I tried running as administrator. Same issues.
Topaz support suggested reinstalling from specific links on the website. Did that. Same issue.
Advised support and have not heard from them in 3 days. I now have no working Studio since it erased the previous version.
Any thoughts would be appreciated.
Thanks.

Hi,

could you launch Windows Task Manager before attempting to start Studio?
Then watch the process list in Task Manager when starting Studio - is there an app called “Topaz Studio 2.exe” showing up (maybe only for a short time if the program crashes)?

Taskmgr_2019-11-13_20-56-37

If Studio crashes you could inspect Windows Event Log. Look for errors in category “Windows protocols / Application” (may be named differently, I translated it to English because my Windows is in German and I don’t know the exact names)
Maybe you find a hint to the reason of the crashes.

I’m having the same problem. After installing the update Studio 2.2 fails to run, while displaying some incomprehensible error messages on screen. My system OS is Windows 7 Pro. Am a long time Topaz user and have never experienced this kind of problem with previous updates (including Studio 2.1). Fortunately. I was able to use the System Restore function to reinstall the deleted Studio 2.1. Will not try to update again until Topaz announces that this apparently widespread issue has been resolved.

Check the Event Viewer for any errors which will be in the application list under Windows logs.

For those that haven’t used it before here is an overview:

Hi Don,
Appreciate the help but nothing appears in the event log and I am not technical enough to go much further.
It is beyond my comprehension that Topaz Support does not address this properly. They have taken an excellent product (Studio 1) and completely botched it up with Studio 2. And I paid how many hundred of dollars for this?

Peter

Firstly don’t know what you mean by this as there isn’t much information to go on.

Before doing what I suggest below go to Settings, Apps and uninstall Studio 2. Do NOT USE third party uninstallers.

The only thing that I can suggest is that you go to the Downloads on the main website, download the installer, right-click on it in the downloads folder and select Run as Administrator after making sure that you have exited from all other programs.

When it asks you to launch the program unclick the checkbox and exit.

Then reboot and click on the desktop icon to run it the first time.

If any of you having this problem are running MacOS, it may be because the user account on your machine doesn’t have Admin privileges (which it shouldn’t if you want to stay safer from malware and other intrusive stuff). Here’s what worked for me.

I added Admin privileges to my normal user account (which requires a reboot) and then did the installation. Once all was set up and working, I removed the Admin privileges, rebooted and all was well.

What I found through extensive trial and error with a similar problem with the new Gigapixel is that the Topaz installation seems to only work properly in a user account that has Admin privileges. And, once installed it will only run in THAT account and not any other one even if the other one has Admin privileges. As part of my troubleshooting, I installed it through the Admin account and it worked fine, but logging back into my regular account it wouldn’t run. So, now I know the PITA routine I have to go through to get Topaz installations to work if they blow up the first time.

This hasn’t been a problem with all of the newer updates, but at least the new Gigapixel and Studio 2 have a serious issue with installation.

Now let’s see.
15 years on Macs, dozen or more strewn out in the backlot, or dumper.
Currently running 4, 3 linked iPads and iphones and I’ve suddenly not got Admin privileges.???

I’m getting to the stage where I’ll come back when the install process is sorted out in about 20 years.

Just for what its worth, I’ve installed several major software and upgrades in the past few weeks, and not once did i get an admin intervention order.

I don’t beta test

Two week now with no TS 2.2.0! The Operations Manager in their tech support keeps telling me to install from their Website (which I have done 7 times!). He says that I could get a remote session from them to troubleshoot. That was a week ago. Repeated emails to him go unanswered.
It appears that others are having similar issues. Why will they not acknowledge the issue and fix it?
At this point just give me my money back and let’s move on.
I have been in the IT industry for over 40 years and this is the worst upgrade and support I have ever seen. Topaz, you should be ashamed of yourselves!

2 Likes

Error%20Code%20Topaz%20Labs%20Studio%202

Same issue here. Using W10 on a Lenovo Extreme X1 2nd Gen.
Please fix the issue.

Raise a support request at the Topaz Labs website please.

topaz%202%20update

All I did was say yes that I wanted to install the latest update while launching the standalone version of Topaz 2 Studio (from the last version 2 to this new update) and I got the error message in the attached screenshot. Even if I hit ignore, it does it on every component it tries to download. It said it had to uninstall my old ‘beta’ version first but I didn’t have a ‘beta’ version - I own the full package. So I let it uninstall and then when it went to install the ‘update’, this all happened. Now I’m without Topaz Studio and don’t know if it wiped out all of my saved presets. I’m not happy this update doesn’t work and has removed my working version. Why is this happening and how to I get my Topaz Studio working?! BTW, everything worked just fine before this latest update so it’s not anything to do with my computer or equipment. I have no problems with any other software and this only occurred after clicking Yes to it asking me to update.

Okay, I got it to install following Don the moderators advice in another post listed below. I downloaded the Studio package and ran it and it launched without issue. Now to see if it has my presets … Thanks Don!

Don’s post:
AiDonDonModerator

4d

Just reinstall it please after downloading from the www.topazlabs.com/downloads page.

The folder for Studio 2 has changed to the one with LLC at the end. Remember to run it as a standalone first and if you are using the application as a plug-in make sure all hosts are shut down before running the

Yay! It saved my presets! So I guess the update doesn’t work so well when letting the application do it but if you download Topaz Studio here: https://topazlabs.com/downloads/ and run that, it does work. Oh well, at least it works! :slightly_smiling_face:

1 Like

SOLUTION FOUND: In my case it helped to install the latest Microsoft Visual C++ package available on https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads.

  1. Uninstall TOPAZ LABS STUDIO 2.2
  2. Download and update/install latest the Microsoft Visual C++
  3. Reboot your System
  4. Reinstall TOPAZ LABS STUDIO 2.2

Microsoft Visual C++ (choose either the)
x86: vc_redist.x86.exe or
x64: vc_redist.x64.exe
package, depending on your system architecture (most likely x64).

Hope it helps!
Cheers, Thomas

A post was merged into an existing topic: Please do not update to Big Sur Mac OS