Stuck downloading 'model'

Stuck downloading ‘model’
I have bought TopazVideoEnhanceAI-2.0.0-windows-x64-Full-Installer.exe, and also have the updates 2.3, 2.4, and 2.6.
‘A file for this model needs to be downloaded to give you the best possible speed’. Downloads up to 100% then ‘Loading AI Model’, ‘If the model has been changed, this may take a minute or two. Note that if the model cannot be found locally, it will be downloaded from the internet’.
Then if goes back to downloading, and again, and again…
Then this box pops up 'Unable to load the selected model. If this errro persists, try lowering
the VRAM usage in the Preferences. I tried that with my NVIDIA GeForce 9600 GT card, and
also using my CPU, neither worked.
Help anyone?

Hi there! There are many things that could be causing this issue, one of them being your internet connection or any server blockers. I would recommend reaching out to our support team.

Just noticed that update 3.0 is available…downloading now. When did Topaz start charging for updates? Starting with what version?

Where do topaz downloads download to? The 3.0 download finished, and the program just ended, did not restart, and couldn’t find the 3.0 file in the normal download location. Also checked my This PC downloads, not there. Does it going someplace else?

Does the update download go directly to your ‘C’ drive? I noticed under Program Files-Topaz Labs LLC-Topaz Video Enhance AI, but when double clicking the Topaz Video Enhance AI.exe, it opened version 2.6.4. Does the update 3.0 go someplace else, or maybe my system doesn’t support 3.0?

I am unsure what the question is here. Topaz Video AI is currently on v3.3.5. We release an update every Tuesday evening.

The installer will be downloaded to the same location all other downloads will be sent, typically this is the “download folder.”

Please reach out to support to get set up :slight_smile:

August 2020.

The next major/minor update after your twelve month licence expired. For example if you had v2.6.4 when your licence expired you would have to purchase a new twelve month licence to obtain v3.0.

1 Like

I cannot seem to download the Enhancement model. All of the other models download fine. There is no problem with my internet connection, and no interference from other software.

Here I am downloading Stabilization:


Then I get to “Enhancement”. It says it needs to download 1518 models!


I let it download and it ALWAYS craps out. Sometimes it gets ten in. Sometimes it gets all the way to 150. But it NEVER finishes. What am I missing?


I’ve even tried opening up Enhancements and (tediously) downloading every model pack individually:


This still yields over 900 files. It gets to about 142 annnnnnd: