Smudge adjustment still not working'

I just downloaded the latest update with hopes that it would fix a problem that has been going on with Topaz Studio since its start. If you open a photo in Photoshop, then transfer it to Topaz Studio via your filter drop down menu and then add a smudge adjustment and hit the ok button to take it back to Photoshop, the picture is totally different. I challenge anyone to try this and see if you get diff results. I have tried to get Topaz to fix this for many, many months but they dont seem to be able to acknowledge there is a problem, much less fix it. Topaz Studio is worthless if you cant get the results you worked on to transfer back to PS.

Have just tried it and it works fine for me. Are you using the HD Preview button?


There’s a slight difference in brightness, but that’s all.

1 Like

Please post a screenshot, at 100%, of both the image in Studio and then the image that is returned to PS. Make sure it is at 100% please and the same area on the image.