SharpenAI replaces Topaz Studio in Photoshop

(Linda) #1

Working on a Smart Object in Photoshop, apply Topaz Studio as a smart filter. While it opens Topaz Studio and saves back to PS, SharpenAI replaces Topaz Studio so that I can not re-open Topaz Studio to make changes to that smart filter.

(Artisan-West) #2

Just need more education. :smirk:

(Linda) #3

Ummm okay? I guess I didn’t make it clear lol

Sharpen AI replaces Topaz Studio in the smart filter stack.

(Artisan-West) #4

I was just joking since it was supposed to be a “smart” filter. I guess you are saying that you used Studio for an adjustment but when re-opening the filter it only opens Sharpen AI. You didn’t say if you had used SAI in Studio or other adjustments which may be relevant.

(Linda) #5

I knew you were joking, but in re-reading my post it sounded confusing even to me! We reported this issue in beta and it seems like they fixed it half-way. I used Studio adjustments only (not the SAI plugin via TS) and when it flowed back to PS it showed SAI not TS, and would only open SAI when double-clicked. Oh my goodness it’s getting worse! LOL.

(Don) #6

@russelltarpley I thought this was fixed?

(Linda) #7

Me too

(Arlen) #8

Same behavior for me, using a Windows 10 computer. If I open Studio as a filter on a Smart Object layer and apply any Adjustment, when I return to PS the smart filter shows Topaz Sharpen AI rather than the adjustment I actually applied. And double-clicking it opens Sharpen AI, not Studio. It used to work fine, before Sharpen AI was released and I installed it.

Please tell me someone is working on this. My workflow nearly always involves Smart Objects, and I know that’s the case for many other people, too. This bug renders that approach useless.

(Gerald) #9

I reported this over a month ago. And it still doesn’t appear to be fixed. Really clobbering my workflow. Does anyone have an idea when it will be fixed?

Sharpen AI as a Photoshop Plugin bug

…Jerry

(Arlen) #10

I agree that is a very overt bug, and crippling to a workflow that uses smart objects. Which means it affects an awful lot of people. Fixing it should be a top priority. If it doesn’t happen soon, I’m going to have to uninstall it. Except that maybe even that won’t work, as I see that in the thread you referenced, one user reported that uninstalling Sharpen A.I. did not fix the problem.

(DougieP) #11

I am also seeing this even today. Good news is I see the new Denoise AI does not have the same issue. No activity on the report I put in some time ago. Like the rest this is destroying my workflow. I am using it as a smart filter as well. Hope to see some movement now that Denoise AI is out as that may have been taking up some of their resources ??? This is by far the buggiest software I have seen from Topaz.