Sharpen AI

I have tried Sharpen AI as both a standalone and a plugin on iMac 10.14.3, 32 GB RAM, and Graphics Card Radeon Pro 580 8192 MB.
In both cases it is extremely slow to process, about 1 minute, which really isn’t practical for my workflow.
Is this to be expected?
Thank you,
Anna

Yes, Sharpen AI requires heavier processing. You might go into the preferences menu and disabling automatic processing to gain finer control over when the processing occurs.

I am running Adobe Photoshop CC 2019 20.0.3 on a 2017 5K iMac.

When I attempt to Launch Topaz Sharpen AI from within Photoshop Topaz Sharpen AI does not launch but instead I get an error message stating that Photoshop has quit unexpectedly. Works fine as standalone. Ticket submitted.

2 Likes

I switched the Sharpening AI preferences from GPU to CPU, with the same result.
Also, I now have the same issue as others are having, which is as a plugin in Photoshop CC 2019, I get an error messagae, that PS has quit.

Unfortunately, I won’t be able to use this product for now, for 2 reasons; I always use Topaz products as PS plugins, and it is too slow to be practical for my workflow.
I do look forward to an improved version, because it does a very good job of sharpening.

One more thing you all might try, is to open as a stand-alone and set Automatically Update Preview to No in the bottom of the right panel. Close the stand-alone and retry as a plugin.

1 Like

Peter, I have exactly the same problem. I took part in the beta-testing and all recent beta versions have worked perfectly in Photoshop. So this comes as a total surprise! I’m sure Topaz will fix this in no time!

This is the last Topaz product I will use. OS Mac 10.14,3, Just purchased Sharpen AI, does not open in Photoshop CC 2019, although it appears under Filter - Topaz Labs. Go to Applications click on Topaz Sharpen Ai is will open as standalone.

This company does not have a hotline number, generate a ticket the get back to with some half baked answer that requires a second ticket. They have your money, their products as poorly supported.

1 Like

I am having the same problems. Standalone it is very slow - I tried one image and all I can say is that it took A LOT more than a minute, a lot more, maybe even 10 minutes. But also, because using it as a plug-in with Capture One seemed to require me to know where to save it to, I took the image from Capture One into Topaz Studio, and then used Sharpen AI as a plugin from there. When I did this, I got a message saying Topaz Studio had crashed. I closed the message and Studio was still running, but Sharpen AI was not opened. Maybe rebooting will help.

But the photo I have tried it on so far seemed very promising.

I guess the speed issue is that my iMac is too old, and the Radeon HD 6770M 512MB graphics card is too slow, though I will try changing the memory from 16 to 32GB.

Using Capture One as a host is similar to that of lightroom. You can use File/Save as an alternative to Save As to alleviate having to choose the output location.

A few eye brows are raised here, Per. You were testing quite heavily on the beta versions. Something has to have gone a bit awry if you have issue with production release. Multiple engineers are looking at it. I believe one may have reached out to you :wink: Hang tight, we are trying to verify, isolate, and remedy.

Yes, this is really strange! I am very stubborn and I was determined to get it to work by deleting (even manually removing files that are not deleted by Topaz uninstaller) and re-installing but nothing worked. I completely reinstalled three times! Sharpen AI crashes immediately when selected as a plugin from Photoshop. I tested both PS 2019 and 2018, both crash. Well, PS does not actually crash but you get a crash message saying that PS has unexpectedly quit. But it is actually still running. Very strange.
When selecting Sharpen AI a message flashes by for a fraction of a second, not nearly long enough to read the text. But I just realized that making a screen recording would “freeze” time and now I know that it is just the “normal” Sharpen AI message.

Yes I was contacted yesterday but I had to go to bed because of the time difference. I am on CET (+7h from you)

Thank you for the reply. I owe you an apology for not noticing that “Save originalfilename” was in the menus at the top. I am now using it as a C1 plugin, though it still crashes when I try to open it as a plugin from Topaz Studio.

You provide an easy way to switch between GPU and CPU processing. Out of curiosity as to which would be best, I tried both, first on a mid-2011 iMac (2.7Ghz i5, 32GB) and then on a 2016 Macbook Pro (2,7Ghz i7, 16GB). On the iMac using CPU was slightly better; on the Macbook it was the other way round, so I guess there is no simple rule about which is going to be fastest. Times for saving the same picture were:
iMac CPU 11mins 45 sec; GPU 12 mins 45 sec
Macbook Pro: CPU 7 min 15 sec; GPU 5 min 48 sec.
Time to upgrade to a fast Windows PC perhaps, because I have been impressed with the results, especially on using the “Stabilize” option on birds taken with a long lens.

The AI Sharpen plugin should exist somewhere on the system, and its name should indicate what plugin it is. I have searched my entire system for all of the plugin files on it (that is, all files with a “plugin” suffix) and could not find anything with a file name that indicated it was AI Sharpen. I don’t believe that the installer unpacked and installed it on my system.

The installer did create an AI Sharpen folder for Photoshop, but there is no AI Sharpen plugin at that location so I am not surprised that Photoshop lists it (the folder is there, and that is what Photoshop looks for), but crashes when trying to access it. There just is no plugin to run.

I will wait until there is a functioning plugin on my system before I will commit to buying it.

My System:
macOS 10.14.3
iMac Retina 5K, 27-inch, 2017
4.2 GHZ Intel Core i7
Memory 32 GB 2400 MHz
Graphics Radeon Pro 580 8192 MB

Installed 1.0.9 update, tested with 990 KB JPG

  1. Still will not run as plug-in in Topaz Studio
  2. Runs correctly as standalone, at the 2 default 50 settings, processing in about 40 seconds
  3. Runs correctly when standalone is called from ON1 Photo RAW, same time, about 40 seconds
  4. Attempted to test plug-in in the unsupported PhotoLine application, which runs the other Topaz plug-ins, but I could not find a plug-in for AI Sharpen. The others are found in the Topaz Studio folder within the Application Support folder. I ran Topaz ReStyle on the test image to verify PhotoLine would run plug-in from that location.

So, I, too, will wait until Topaz Labs provides a plug-in and location.

I find it extremely irritating this plug-in won’t run in Topaz’s own host program, Topaz Studio.

I have the same problem on my Mac Book Pro 2018 Sharpen AI works only as standalone, as plug-in in Topaz studio crashes immediately at launch, on my Windows machine it is ok.

It does run in Studio on my Windows 10 PC but its under the Plug-ins menu (where Adjust, etc are located), not as a Studio adjustment.

1 Like

I can’t find it under the Plug-ins menu on my installation of Studio (1.14.1). Frustrating not to be able to call it from Topaz Studio.

It runs as a stand-alone program - slow, but it runs.
Windows 10 PC

I don’t know if this will help but it should be in a Topaz folder along with other plugins as shown here.

Dianne, try updating to the current version of Studio (v1.14.2). And Sharpen AI v1.0.9. I’m on Win 10 too, and it works from Studio, although I dare say it doesn’t run any faster via Studio than it does as a standalone.

After you update Studio, click on Community, Switch Users and re-sign in. Then also click on Help, Check for Adjustment Updates AND Check for Software updates. Then open an image and try again.

Curious…do you have any of the other Topaz Plug-ins? Do they appear in the Plug-in list?

Correct, it was only added since Studio v1.14.2.

Cheers,
Bart