Sharpen AI v3.2.2 will not save image

I think I’ve been using v3.2.2 for a few weeks now, and haven’t experienced this problem until yesterday. I’m running Windows 10 on my laptop and have never had performance problems with Topaz Labs products. I tried sharpening a jpg filewith Sharpen AI v3.2.2. The program works fine until I pick the ‘Save image’ button. The processing screen immediately indicates ‘Finishing’, the progress bar doesn’t actually start, it just bounces from side to side. Here is a Loom video screen capture:

I let it run for over an hour and the image wasn’t processed. I tried a few other files with no success. I tried a CR3 file from Lightroom Classic (Edit in… Topaz AI Sharpen), which generates a TIF copy for Sharpen AI. I also ran this original small jpg through Gigapixel AI (x2) to generate a TIF, then tried that in Sharpen AI, and that didn’t work either.

Application & Version: Topaz Sharpen AI Version 3.2.2
Operating System: Windows 10 Version 2009
Graphics Hardware: NVIDIA GeForce GTX 1060/PCIe/SSE2
OpenGL Driver: 3.3.0 NVIDIA 471.96
CPU RAM: 32653 MB
Video RAM: 6144 MB
Preview Limit: 7781 Pixels

Try updating the Studio Driver for your GPU to the latest version.

Could you be a little more specific?

I’ve updated my Graphics Driver (NVIDIA GeForce GTX 1060) to the latest version. I wasn’t aware that there was a ‘Studio’ driver. Is this a driver shared by all of my Topaz Labs apps - Gigapixel AI, DeNoise AI, Sharpen AI, etc.?

Update: I think I found the answer. After opening the NVIDIA GeForce Experience, I discovered options for Game Ready Driver and Studio Driver. It defaults to the Game Ready Driver. I switched to the Studio Driver and downloaded the latest version 472.39 (10/26/21).

I also updated from Windows 10 v20H2 to v21H1, today. Looking at my update history, I see an automatic cumulative update occurred on 10/16/21 and it makes me wonder if there was something in there that could’ve adversely affected Sharpen AI. If it did, it didn’t do anything to harm my other Topaz apps.

This did not make a difference. Sharpen AI still doesn’t process my images. The progress indicator bar is not showing the blue line growing (making progress), it just bounces back and forth.

Other options to try:

  • in preferences change to using the GPU (1060) rather than Auto
  • open from the file dialog rather than dragging onto the app
  • reinstall the app

If these don’t work raise a support request at the main website.

I tried all those things earlier. Still doesn’t save.

Also, I used to work in software development for a company that produced audio/video related products. They included Sound Forge, ACID, CD Architect, DVD Architect, Vegas Video, etc. Our developers created code libraries that performed functions that were common to all apps. So instead of reinventing things for each app, these libraries were shared across apps. So when an improvement was made to the libraries during the development of a new release for one of the apps, all the other apps could also benefit, depending on their development cycle and what branch of the code tree they were using. So there’s a possibility that an update to one of the libraries might cause a problem with another app and unfortunately, QA missed it during testing. However, we were pretty thorough and rarely missed these sorts of things.

I assume for efficiency sake, Topaz Labs also uses their in-house code libraries as well. And, since none of the other Topaz apps I own and use regularly (DeNoise, Gigapixel) fail to save. I wonder why it is only happening with Sharpen.

BTW, I raised a support request on Friday 11/5, but it was after 5 PM CST. I’m hoping they get back to me this coming week. I brought it up here in the forum to find out if anybody else was having this problem and to see if they already learned how to fix it.

1 Like

I finally got it working after following instructions from Topaz Labs tech support. I had to uninstall and then delete registry entries for Sharpen AI. Then I reinstalled using the full installer instead of the online installer.

1 Like

I am having the same issue and was searching for a solution. Can you share the instructions you got from tech support?