Sharpen AI v2.0.5 seems broken [resolved]

v1.4.6 works as expected.

v2.0.5 doesn’t appear to process any result at all that I can tell. Doing a reset calibrate doesn’t change anything for the better.

Did I see this behavior also mentioned somewhere else for some v2.x? Not sure if that was AMD specific or just in general.


Start Sharpen AI as a standalone, open an image and go to Preferences and click on reset, do an update on the image and it should recalibrate the processing. That may help.


Already did that as mentioned above; didn’t help.

1 Like

Interesting you mention this for this version (2.0.5) using an AMD processor (I’m on Win 10 PC)… I’m definitely seeing sharpening in my setup with the AMD, but in this release the Masking is doing very weird things that it didn’t do in the previous versions since they intro’d the masking.

Now my Overlay is blinking on & off as I paint it on or remove it by switching to the black (looks like those film noir scenes with the neon lights blinking on & off outside the dive apartment bldg from some 1940’s era or something) and going in and out of view when I paint with the Auto Update “on”. It definitely wasn’t doing that before b/c I suggested adding the masking feature and have been very attuned to its bhvr.

I rolled back to v2.0.0 and that is working. At least, I get visible results and I get the processing dialog…v2.0.5 never brings that up at all.

So, it appears something got broken along the way to v2.0.5.

As an aside, there is broken dirty-tag logic in the File->Close-all-images in v2.0.0. But, I’ll have to recheck that in a later version to see if it is still broken or subsequently fixed.

1 Like

I didn’t think we could do that! Other software providers offer archives of their past releases for users to install or roll back to. I have saved the installers as released from Topaz (rather than updating in app) for the very purpose that if something got screwed up I could go back a generation I liked working with and that worked well. But I’ve found their newer releases’ installers over-write their older installers (hunh!?! - never seen that elsewhere) and I can’t go back once I’ve updated - unless I roll back my whole PC to the point before the update was run (which I don’t wanna do and shouldn’t have to do). There should be a releases archive page with all the generations that can all be accessed & used - not just the current products’ releases and the “Classics”.

I don’t know if anyone from Support monitors these pages and will pass this info along to the devs… So, probably we need to report the issues on a “real” Tech Spt page vs in this user forum.

Not just the AMD GPU, I have nVidia 1060 on my laptop. It seems every minor v2 updates, it’s taking longer and longer to process the images (including the previews). I only spent about 10 minutes with the new version, and it felt very unpolished/untested.

The software seems to ignore the unchecked auto-update at times. When I toggle to Auto for the Select Mode, I can’t tell if it’s in Auto or not (the sharpness/suppressed noise values were updated on the second time I selected Auto).

Masking: 1. can’t change the brush size with mouse (work with left/right arrow keys); and 2. screen blinked on and off (full black) while I paint.

Save: I was unable to make any changes to the save dialog, and when I minimized then maximized the window, the whole window went black until I tried to quit the app, and then the window refreshed, with the quit warning. [UPDATE: this happened when I changed format from jpg to tif]

1 Like

At least on my system everything is working well, and I don’t see any of the symptoms being mentioned by others.

Application & Version: Topaz Sharpen AI Version 2.0.5

Operating System: Windows 10 (10.0)

Graphics Hardware: GeForce RTX 2070 SUPER/PCIe/SSE2 (GPU Processing Setting)

OpenGL Driver: 3.3.0 NVIDIA 442.74

CPU RAM: 16312 MB (AMD Ryzen 7 3700X)

Video RAM: 8192 MB (High Memory Usage Setting)

Preview Limit: 8000 Pixels

Yes, glad you mentioned the (1) Brush Sizing in Masking also! It is definitely a problem in 2.0.5. I can use the bracket keys for only 3 taps before they won’t work anymore as a resizing option. And (2), while adjusting the Brush diameter/size, this newest release of SAI also won’t hold the Threshold I’ve set - it automatically Reverts back to the Default Setting that appears when the masking interface is 1st opened every time I resize the Brush. It didn’t do that previously. All of those things are in addn to that (3) awful, rapid, continuous Blinking Overlay (on, off, on, off, disappear, come back, on, off).

As stated above, I’m using Win 10 PC, Ps CC 2020 SAI plugin, AMD processor & SAI 2.0.5. All properly installed, reset, re-benchmarked, etc. Did not have issues stated in the various posts above in the last (& perhaps 2 last) versions of this product.

Batch process is not working at all
I click pn it and SharpAI just stops

1 Like

Same here… Denoise AI & Sharpen AI both stopped working with the latest update.

1 Like

Interesting. I spent time doing systematic testing tonight, writing down each Use Cases as I go and the result and so far, everything works on my system as I expected. I do see the flickering mask with auto refresh ON, but not sure if this is as designed or not. Could be rather annoying on slower system I suppose. Perhaps auto refresh should be turned off when in masking mode and the masking tool is active. At first I didn’t understand the Apply/Cancel Mask function, but once I understood that it meant Save/Cancel Mask CHANGES it made much sense. Using memory intensive preference mode. I have not tested the batch mode yet, but everything seems OK for me.

Application & Version: Topaz Sharpen AI Version 2.0.5
Operating System: Windows 10 (10.0)
Graphics Hardware: AMD Radeon™ R9 270
OpenGL Driver: 3.3.13476 Core Profile Forward-Compatible Context
CPU RAM: 16335 MB
Video RAM: 2048 MB
Preview Limit: 4377 Pixels

1 Like

I went back and re-installed v2.0.5. Now things appear to be working as expected. Not exactly sure why.

I think this is/was an installer issue, but it’s very difficult to reproduce so I’m not sure if I can nail it down. I would point out that I do not install to the default location…I install apps to a secondary drive.

Load the software add the pictures.
Then clickon select all the pictures then click auto
Then click on Batch and then completely crash’s and nothing happens and has been closed as non of the software nothing happens
I would consider buying this software but not going to buy if doesnt work correctly
Many thanks

Tried the batch process on my system, added 3 images, started the process and it completed without issue. I conclude this is not a generalized issue.

I’m running Windows 10 using an AMD Ryzen 5 2600x CPU and an AMD Radeon RX580 GPU. I recently updated Sharpen AI to the new 2.0.5 version. It seems to work fine on a single file and the masking brush also works. No issues to report. JLG, I also have it installed to my D: drive, not the default.

I downloaded the v2.0.5 online installer and everything has now magically started working as expected.

We all need some magic at times. :smiley: