Sharpen AI (new install) crashes as soon as I select with brush

I have just done my first Topaz install on a Windows 11 machine:

Application & Version: Topaz Sharpen AI Version 3.3.2
Operating System: Windows 10 Version 2009
Graphics Hardware: NVIDIA GeForce RTX 3070/PCIe/SSE2
OpenGL Driver: 3.3.0 NVIDIA 472.47
CPU RAM: 65450 MB
Video RAM: 8192 MB
Preview Limit: 8000 Pixels

(NOTE - yes it is Windows 11, even though Topax seems to think it is Windows 10)

Each time I open an image (just doing a simple drag from File Explorer here) and do the following:

  • Select>Custom>Refine
  • Modify>Clear
  • Add

The application closes with no error messages at all. Am I doing something obviously wrong, or do I have an issue with the software? I split the install across an SSD and Hard DRive. I’m hoping that isn’t causing any issues.

All help/pointers would be appreciated. I’ve raised a ticket with the support desk.

Oh dear, AI DeNoise is also unexpectedly quitting. So I suspect a general incompatibility issue. But how to track it down? 🤷🏼

Same issue. I use it as an external editor on LRC and it crashes with the brush tool when adding for subtracting to a mask. even if I don’t mask, when I save the edit, Sharpen AI doesn’t update the file and what is passed to lightroom is an unedited (not sharpened) tiff image.
I’m also on Windows 11.

Tech Support have been in touch. There is a known bug (obviously not known to me) with the edge detection on the brush, which is a feature I was using. Fingers crossed this is the issue and that it gets fixed.

I love software which has a feature enabled that the developers know is broken! Fills you with confidence.

thanks for the update

I have recently bought and installed Topaz Sharpen, Denoise and Gigapixel. The last two works fine, but Sharpen keeps crashing. Yazan at Topaz Labs tried to help me uninstall completely, even tried by installing v 3.3.5. It will work fine for a couple of images, and then all of a sudden just give me a blank screen. Does anybody else experience this instability?
I have already installed the latest drivers, and checked everything else as advised by Topaz…

The issue I was having was fixed as soon as I stopped using edge detection. Other than that I have not had any issues.