Sharpen AI 4.1.0 (External?) won't use altered model parameters

I don’t see any other topics with people having this happen, but…

I sent a .NEF image from Lightroom to Sharpen AI 4.1.0. There, I left it in single image mode and selected the “Sharpen Model”. It used Out of Focus - Very Noisy.
The defaults were Remove Blur: 38 and Suppress Noise: 58.

I CHANGED the values from 38 to 80 and from 58 to 75.
The model parameters showed the new values, but the image line at the bottom of the screen did not change. The values there stayed S: 38 and N: 58.

When I processed the image it said it used 38 and 58 for the processing.

I then OPENED Sharpen AI SEPARATE from Lightroom, opened the same image and attempted to do the same thing. I got the same results - it will not accept my altered model parameters.

HOW do I get Sharpen AI to USE the parameters I set instead of what IT has as the defaults?

I just tried going OUT of the “Sharpen Model” and selecting ANY of the models. They ALL stay at the defaults and won’t use the values I change to.

I just removed the software and reinstalled it. Made no difference. I then rebooted the system and ran the same image again. Same result. Sharpen AI says the value should be whatever the default is no matter which model I pick or what I change the values to.

I don’t REMEMBER this being this way previously, so what do now?

Went back to 4.02. Works fine. Did a poor job sharpening the test image, but the software DID allow me to change the model settings.

I ALSO re-installed 4.1.0.2b and IT does the same thing 4.1.0 does. Won’t let me change the model settings.

Is there something else I need to do to get somebody from Topaz to check and see if there’s a problem with Sharpen or if it’s a problem on my end?

I seem to have the same problem. I can’t find a way to have the model parameter values change what’s listed for the selected images. They all stay with the default parameters no mater what I try.

Unfortunately, Topaz has been totally silent on this, and I haven’t seen a new version that addresses it either… BUT, there don’t appear to be dozens of people in here complaining about the same problem, so we may be screwed.

Same problem here!

Well, it’s nice not to be the only one having the problem… Now can we get a SOLUTION?