Sharpen 2.2.4 Incredibly slow

I’ve just downloaded Topaz Sharpen 2.2.4 and it’s incredibly slow, the previous version was reasonably fast. Any ideas?

No ideas, sorry

I didn’t really notice any significant change in speed after the update to 2.2.4, certainly nothing to warrant the term “incredibly slow”

For reference here are the times I’m seeing on 2.2.4, using on it on a 4031px by 3025px JPG image.
Sharpen-times

I don’t have any times on record for the previous version to do a proper comparison.

Please go to Help-> Graphics info then press Copy and paste the info here.

Thanks for coming bck to me. Here’s my graphics info. I just ran the same image again and it took exctly 9 minutes to apply my changes. I’ve also tried it on another similar spec laptop and it took just as long.

Application & Version: Topaz Sharpen AI Version 2.2.4
Operating System: Windows 10 Version 2009
Graphics Hardware: GeForce GTX 1050/PCIe/SSE2
OpenGL Driver: 3.3.0 NVIDIA 460.89
CPU RAM: 32619 MB
Video RAM: 4096 MB
Preview Limit: 6038 Pixels

You may need to post the image to a file sharing site where it can be downloaded from then post a screenshot of the parameters used for processing. As, for me, it is the same as the previous version with a 6000x4000 image:

And my Notebook is similar to yours except for less RAM than you and my driver is updated:
image

You can try updating the NVIDIA driver and see if that makes a difference, or maybe there is something running that slows the process down.

I must admit, I’d forgotten to update the graphics card driver for a while, so I’ve done that now and the processing time on the same imaged has dropped from 9 minutes to 2 minutes which seems to be what most of the problem was. Thanks for your help.

2 Likes

I never had a problem before this latest update but with the update the software runs very slowly.

Mine is still not good even with the updated graphics card driver. It’s certainly not anything like it was on the previous version.

Please go to Help-> Graphics info then press Copy and paste the info here.

Application & Version: Topaz Sharpen AI Version 2.2.4

Operating System: macOS 10.16

Graphics Hardware: Intel® UHD Graphics 630

OpenGL Driver: 4.1 INTEL-16.1.11

CPU RAM: 8192 MB

Video RAM: 2047 MB

Preview Limit: 4492 Pixels

Go to preferences and see if OpenVINO is selected, if not press Calibrate and it should be selected as using the HD630 just wont cut it.

OpenVINO is selected.

If HD630 won’t cut it, what am I to do? The software worked fine prior to this update. Is there a way to go back to the previous version?

Just do as I asked please.

As you instructed, I did go to preferences and checked to see if OpenVINO was selected. It was selected already.

Prior to this update, the process took about 30 seconds, at most, to complete. Now it takes about 8 minutes.

Is there any way to revert back to the previous version? Or is there something else I can try to improve the performance?

It really doesn’t sound right, it may be that there is some app that is now using resources or there was a OS updates.

Also, when you say it previously took 30 seconds to complete, it also depends on pixel dimensions of the image, the sharpening model used and the settings. All images will have different processing times.

If you want to revert you can see the releases on this forum:

https://community.topazlabs.com/c/releases/sharpen-ai

Mine is still four times worse than it was. On two different laptops 30 seconds applying has now turned into two minutes. I’ve already posted the set up on those. Even taking into account different image sizes, there seems to be something in this update thats causing a slowdown.

My best suggestion is to raise a support request at the main website as we have similar systems but I haven’t experienced a slowdown.

Thanks for trying to help. I really appreciate it. I understand that the time to process depends on the image dimensions but this is a major increase in time on every image I’ve tried.