RTX 3080 VRAM issues after installing latest driver - VEAI

After upgrading to the latest Nvidia driver (465.89, released 3/30), I am now getting the “Unable to run the selected model. If this error persists, try lowering your VRAM usage in preferences” error. Prior to the new driver, I was able to run all of the Artemis models (including the new ones) on the highest VRAM setting. Setting to the lowest usage yields the same result. After searching the error, I also tried enabling page file on the secondary SSD where I have VEAI installed as recommended.

I was getting this error in v2.1.0, so I also tried upgrading to 2.1.1 and still have the issue.

I tested all models, all output modes, on lowest compression for video.

I also tested previous videos that worked fine, and also tested the videos from the tutorial.

Any recommendations other than downgrading? I’m using the game-ready driver. After searching around on various forums to determine if perhaps the studio driver would be better, it appears there is no benefit to running Studio driver over game-ready from a performance perspective.

6 Likes

Well that was a wild ride. It ended up working with the new driver after disabling Hardware-accelerated GPU scheduling in Win10 under Settings --> System --> Graphics --> Default graphics settings.

2 Likes

I’ve had the same problem. I suspected it was related to the scheduler from one of the error messages in event viewer. I haven’t tested changing the setting yet. Hopefully Nvidia will fix this.

I have a 3090 and this VRAM issue and disabling GPU scheduling doesnt fix it for me.

1 Like

On my 3070 disabling GPU scheduling seems to improve things for me, but not fix it completely. Also, output from the Theia model is messed up if the output is scaled.

In event viewer the driver crash is accompanied by these two error messages:

\Device\Video3
Graphics Exception: ESR 0x407020=0x100 0x407028=0x0 0x40702c=0xd238f 0x407030=0x7

\Device\Video3
Graphics Exception: SKEDCHECK36_DEPENDENCE_COUNTER_UNDERFLOW failed

RTX 3090 here. Yeah, this is really frustrating. I hope it gets fixed soon.

1 Like

Perhaps it’s worthwhile to post about it on r/nvidia?

The gaming community does beta testing drivers for the working community.

Its not about performance its about that it does work for sure, thats why there are studio drivers and professional cards.

After still having performance issues, and issues elsewhere outside of VEAI, I ended up using DDU to completely remove the video driver and went back to N-1 version of the GRD. Also, there were other updates outstanding with the release of the latest GRD. I installed a pending EVGA card firmware update, and then MSI bios update, which were both related to the latest GRD that enabled ReBar. After about a week I got antsy to try the new driver again, and it is now working fine. No more VRAM issues.

So I would say:

  1. Try disabling GPU scheduling first.
  2. If no luck, try DDU to the n-1 driver, check for card firmware updates, BIOS/VBIOS updates, and then try the latest driver again if you need it outside VEAI. If it fails again you can always revert.
1 Like

Updating BIOS fixed it for me. Thanks.

RTX 3080 here and i had the same problem.

Installing “Studio Driver (SD)” instead of “Game Ready Driver (GRD)” fixed the problem for me.

1 Like

Can confirm this works. And there should be no issues playing games on Studio Drivers.
Thanks for the tip.

I installed the 461.72 GRD and it worked, I then installed the 461.92 STD and it works as well, I’m guessing that the 461.92 GRD would work too, but unfortunately, the 465.89 kills it for me…

The 465.89 broke VEAI for me, and updating to 466.11 doesnt fix it either

Well THAT sucks, I’m guessing that the VEAI devs don’t/refuse to use NVidia cards or are using outdated drivers (If that’s the case, WHY!?) as this issue could have easily been found and fixed already… :angry:

EDIT: Ironic too as it specifically lists VEAI as one of the programs supported by this patch!

EDIT2, Yeah, sticking with the studio driver is not a bad idea after all, as this is an invaluable part of my encoding pipeline, especially effective for my 3D animations as well!

It’s on Nvidia side. Driver’s meant to help the GPUs run effectively with the applications, because Gaming does not use the GPU heavily like AI applications. For professional apps, it takes more time for developers to work with Nvidia to implement new features or fix current bugs. There’s a reason for Studio Driver to exist. If you think VEAI doesn’t work well on your computer, you should delete it and play minecraft instead since it runs well on any new Gaming driver.

2 Likes

The childish snark is uncalled for, grow up…

Yes, you should.

1 Like

That made no sense, it’s pretty much a “no you” playground argument…

How the conversation should have gone…

It’s on Nvidia side. Driver’s meant to help the GPUs run effectively with the applications, because Gaming does not use the GPU heavily like AI applications. For professional apps, it takes more time for developers to work with Nvidia to implement new features or fix current bugs. There’s a reason for Studio Driver to exist, as it’s much better for non-gaming applications…

Hmm, you’re right, thanks for the information!

Sure, no problem, as a beta tester I have a pretty good perspective on how the program works, and am happy to share that knowledge.

That’s how you can go about conversations with people you disagree with…

EDIT: Admittedly you’re still correct, I’m going to stick with the Studio drivers after all.
EDIT2 Edited out the harshness…

I believe the updated Studio Nvidia drivers are now available for the RTX 3000.

Release Date: 2021.4.14

https://www.nvidia.com/Download/driverResults.aspx/172913/en-us

Studio Application Updates

  • Topaz Sharpen AI and Denoise AI: RTX-acceleration of AI algorithms
  • Notch Builder: Tensor Core and AI support for real-time body tracking and background removal
  • OBS Studio: noise removal directly in OBS
  • Autodesk Arnold: support for GPU-accelerated NanoVDB

I got my new Laptop coming soon
AMD Ryzen™ 9 Eight Core Processor 5900HX
64GB Corsair 2666MHz SODIMM DDR4
NVIDIA® GeForce® RTX 3070 - 8.0GB GDDR6

So cant wait to do some upscaling.

3 Likes