PS CC 22.5 and Gigapixel v5.6.1

Good day,

I just upgraded to Gigapixel v5.6.1 and use PS CC 22.5. Since the upgrade I can not successfully use the PS Gigapixel plugin. It appears to be working fine but when it goes to 100% and then back to PS, PS crashes. I’ve tried the CC PS recommendations by disabling GPU but still the same issue. I am not sure what else to provide here but any suggestions are welcome. Note: I can us v.5.6.1 as program but no longer as a PS plugin.


Open the standalone and go to the Help menu, select Graphics info, press the Copy button then paste the information here.

Thank you - here is the information
Application & Version: Topaz Gigapixel AI Version 5.6.1

Operating System: Windows 10 Version 2009

Graphics Hardware: NVIDIA GeForce GTX 1050/PCIe/SSE2

OpenGL Driver: 3.3.0 NVIDIA 471.68

CPU RAM: 16242 MB

Video RAM: 2048 MB

Preview Limit: 4067 Pixels

I would raise a support request at the main website as it must be an issue with Your PS environment where support may be able to help. Your GPU should be OK but it may be that Gigapixel is assuming 2GB is available. I have a similar setup but my GPU has 4GB and using from Affinity Photo is OK.