Process ran out of memory. Couldn't generate output from the model for: Identity. - Process ran out of memory

Getting a - Process ran out of memory. Couldn’t generate output from the model for: Identity.

  • Process ran out of memory.

Error Using 3.1.10

I am also having this problem. Four 720p videos of no more than 45 minutes fail with the “Out of Memory” error when using Gaia to upscale to 1080p. I have 16GB of system memory on a Base Model M1 Pro 16" Macbook pro. Is there anything that I can do to manage this? MacOS activity monitor shows 12.44gb memory used so I would have thought I should be fine.

@topaz i’m running 3.6 GHz 10-Core Intel Core i9 AMD Radeon Pro 5300 4 GB 16 GB 2667 MHz DDR4 Running Ventura 13.2.1 (22D68), using an EXTERNAL hard drive 7200RPM with 4.19 TB Available. I’m guessing weekends don’t have any support but I am under a deadline and would love some support thanks.


Have a Mac with an M1 Max, 64 GB memory and running Ventura 13.4.1. Topaz version 3.3.2
After running out of memory, reboot and the only running application was Topaz. Again running out of memory.
Tried the version 3.0.0 which worked fine ending the 2 clips. Strange that in the second clip the watermarked Topaz icon was captured in the clip. The first clip was fine.
Running after a few hours with a non-usable current version and an old version who watermarks me, this is simply annoying.