Problems usinging Gigapixel 7.1.1 plugin in photoshop

On MacBook Pro (M3 Pro Processor, 36 GB RAM, OS Sonoma 14.4.1). When I run GigaPixel 7.1.1. (think this is Beta) from photoshop, when the Export to Photoshop button is engaged, it appears that nothing has happened. The size (in Pixels and in inches) of the image hasn’t changed, and the Gigapixel layer is null!!! So, I tried another approach: dragged the file into Gigapixel, upscaled it, and saved it to the correct folder. Sure enough, the file size increased appropriately, and displayed correctly in Preview. HOWEVER, when I opened that file in Photoshop, it appeared blank (all black). This feels like a bug. I’ve used photoshop for years (with Gigapixel), and it had worked like a charm. GigaPx is an integral part of my workflow (bird, wildlife, and action photographer), and it just has to work. Help me fix this!

Also, one small (but annoying) detail. On returning to photoshop from GigaPixel, DeNoiseAI, and SharpenAI, control is not returned to the window that invoked the plugin. This means you have to click on the window to re-activate it. That is NOT standard MacOS behavior. It’s a pain to have to click the window each time. Please fix that too. (That’s not just a Beta problem, either)!


Gigapixel v7.1.1 isn’t a beta, but some of the models are like Low Res v2 and Recovery.

Are you on the most recent version of Photoshop? If not, try updating it and see if it helps.

Sadly for the small Photoshop conflict, DeNoise AI and Sharpen AI are discontinued so this isn’t something that’ll be solved. However, I will let them know about this for Gigapixel and see what we can do.

Version of Photoshop is 25.6- Up to date.

So if DeNoise and SharpenAI are no longer supported, where is that functionality? PhotoAI?



Yes! Photo AI has essentially replaced those applications and has a remove noise, sharpen, upscale tool and more packaged with it.

Have exactly the same problem. PS is up to date. What to do? Back to previous or…

1 Like

I’m having the same problem. Just updated PS, LR and GP. Agggh!

1 Like

Same here! Need a quick solution or it’s useless!

1 Like

@Wil_Vermeesch @thomas.niblick @johannes.zwirner

Please reach out to Support (

1 Like

I have this same issue

1 Like

Please reach out to Support ( so we can track this issue and work with you guys individually to see if there is a common culprit.

Same problem here. An empty layer in PS after upscaling with the Gigapixal plugin. It completely wacks out my Photoshop making it unresponsive and the image window is all black.

After update Gigapixel 7.1.2 is my problem solved.

1 Like

I updated to 7.1.2. Different issues: now it’s super slow. Maybe it’s not taking advantage of the M3 processor?

1 Like

Great to hear!

That is very possible. Try changing the AI Processor settings.

  1. Open Gigapixel as a standalone.

  2. Go to Edit > Preferences.

  3. In the General section of the Preferences window, change the AI Processor to your M3.