Problem moving from Light Room to Glow II and back

I just purchased Glow II and find it fascinating. However, when I take an image from Light Room (subscription based) to Glow II, do the processing, then click on the bottom right OK icon, the image goes back to LR, but all I have is a black screen.

But if I take an image right into Glow II and not from LR, the bottom icon is a “Save As” function. I’ve obviously got a setting or two wrong.

How do I successfully take an image I’ve processed in LR, send to GlowII, then send it back to LR as a newly processed image?

Thanks! David

HI,

Firstly provide a little technical information please:

  • What version of Glow?
  • If you have the standalone version did you know the latest upgrade is Topaz Studio Adjustments? You are entitled to a free upgrade.
  • Are you using it via Topaz Studio or directly?
  • What is your PC operating environment … Operating System, RAM, GPU version?
  • Is your GPU up to date with the latest drivers from the GPU manufacturer?

Lastly the technical requirements for Glow are as follows:

Topaz Glow v2

Topaz Studio

Hi Don,

Thanks for the quick reply! This is Glow II. I have a brand new Win10 64
bit machine. 7th Gen I5 processor, 12 gigs of RAM. Intell HD Graphics
630. I downloaded GlowII a couple of days ago from the Topaz webpage.

Thanks again!

David

Next question is how big is the image you are trying to process, in pixels not MB, and have you tried a smaller image or do all images return with a black result?

Note that the HD 630 is just acceptable … do you have a second GPU on the system?

No second GPU. I’ve not had this problem with the other Topaz modules I
use. The problem only happens when transferring from LR. If I load the
image directly into Glow, there’s not a problem. I’ll check with HP to see
if there is a driver update sometime today.

David

Glow has different technical requirements to other Topaz plugins, specifically GPU & Open GL as detailed in the link above, if you can do the following to see if it is a size or resources issue:

  1. Select the image in LR to send to Glow,
  2. Send the image to Glow,
  3. Exit without applying or saving any effect,
  4. Right-click on the generated image in LR and select ‘Show in Explorer’,
  5. Take a copy of that image and place it elsewhere.

Then edit that image usine the Glow Stand-alone and save as using the same settings as you exported the image … e.g. JPG, TIFF using maximum quality and see if you have the same issue. If it still saves as black try resizing to see if that makes a difference, or try exiting from LR and see if that makes a difference.

I updated the graphics driver. That fixed it.

David

2 Likes