Photo AI removes metadata

I’m using Photo AI with Lightroom Classic. I have Lightroom set to automatically write metadata to the files.

When I select an image and use “edit in” to send it to Photo AI the resulting tiff has all the metadata of the original raw file. But when I open a raw file with File > Plugin Extras > Photo AI, the resulting dng file has had all the metadata removed. I know that Topaz recommends using “Plugin Extras” instead of “Edit In,” but this creates a lot of extra work. I can probably reconfigure my workflow for new photos, but I have a lot of images in LR that have already been keyworded, captioned, etc, as well as having some metadata applied on importing.

Any suggestions? Are there any plans to fix this?



PAI v1.1.1 * * ExifTool is now embedded in the app instead of being run as a separate process*

v 1.1.1 Released 12/8/22. ExifTool does a lot (all?) of the meta-data reading/writing. You might try this version and see if you notice any improved functionality.

I just installed the update and processed a couple of files. There’s no difference from the previous version - all the metadata I’ve entered in LR is missing from the dng file. The only IPTC metadata that remains are the creation date and my name, both of which were embedded by the camera.

Unfortunate that didn’t fix it. Next step would be to open a support ticket (if you haven’t already).

I used Photo AI for the first time yesterday and discovered the same thing. Anyone know if this is true for all the Topaz products? If not, perhaps it will be fixed in an update?

I also found that unlike other DNG producing apps I have used, Photo AI only embeds a very small Jpeg. I use Photo Mechanic which uses embedded Jpegs for speed. It can render using the Raw data but it slows down the application. The rendered DNG also has weird color but that may be a Photo Mechanic problem.

I had the same problem and found following information :

Metadata will fail to copy or the output DNG file is invalid if you are using the Lightroom Classic Edit in > Topaz Photo AI and there are special characters in the file name or file path to the image location.

Unfortunately it is not allowed to post a link here.
Try a (google) search for “Metadata Not Copied with Lightroom Plugin > Topaz Photo AI”
to find the article with the solution instructions. This solved the problem for me.

Not exactly concerning ALL the metadata … but I have found that using PhotoAI changes the data concerning the ISO used. It will, for example, consistently change ISO 800 to ISO 15 and ISO 400 to ISO 12 (and others). Now I know it does this I change them back but it would be good to prevent it doing this in the first place. The only other interactors would be Win 11 itself or Faststone Image Viewer (nothing else is running).

Sorry, I goofed. That was meant for the topic as a whole, not simply Thomas.sperl.


Same problem here!

I bought Photo AI beside Sharpen AI for improving my workflow on using Topaz on RAWs using LR plugin manager. Unfortunately this looses a lot, if not all metadata! Especially loosing the star rating is annoying, its essential for the overall workflow with culling, selecting and final editing on base of the .dng file.

Any fix for this?

Ciao, Bernd

Thanks Thomas for the hint! Tried the UTF Beta setting with no positive result in my case. Stars, GPS and other Meta data still removed on the .dng during Photo AI processing.
Waiting for Topaz - again…

I found some EXIF data was changed in DNG file. This issue is solved in latest version 1.1.9.
Keep in mind that all metadata you set in LR ist not saved into the original RAW file. You only can save it manually or automatic into a XMP file.

Hi Thomas, ooh - you’re right with the metadata like the star rating not saved in the .CR3 - thanks a lot, i wasn’t aware of! So not to blame Topaz but maybe Adobe :-). Ciao, Bernd