Photo AI - Fails to open image from Lightroom

When Opening an image to be edited in Photo AI it creates an copy of the image in LR with the extension .TIF but I won’t open the file on Topaz AI. This should happen automatically like when we edit an image in PS and after we save it, it will automatically show up back in LR with all the changes made in PS.

LR creates that copy and sends it to Photo AI, check that the External Editor calls the correct version of Photo AI.

I have the same problem.
The external editor was set to Gigapixel.
I changed it to Topaz AI but the problem persists on some images only.
I get the dup image but Topaz AI never opens.

It’s Photo AI not Topaz AI you need to have in the external editor preset and PSD is not supported (if you are selecting it)

I just picked Topaz Photo Ai off the selection list.
Tried it only on raw files and it worked every once in a while but mostly just created the tiff and quit.

That is not Photo AI, Lightroom creates the image. And you should always send as a TIFF.

Same issue. Send as told as a tiff-file, makes a copy with LR settings, opens Photo AI but with blank start-up window telling me to choose picture or drop it. When I close Photo AI a tiff.copy with my image is there in catalog