Photo AI 1.3.3 - Images are not upscaled any more using CLI

When running the CLI via tpai.exe myinputfile.png images are no longer upscaled.
It worked fine in previous versions (1.3.1, 1.3.0…). Must be some new bug.
The output displays

Auto Upscaling Type: auto
Auto Upscale Factor: 4

When I use the UI everything works and the output files are correctly upscaled.

Steps to reproduce issue:

  1. Fresh install of PhotoAI 1.3.3. It auto downloaded additional models from the Internet for my machine.
  2. Set Preferences: CPU only
  3. Run tpai.exe on any picture. The result file will have the same resolution as the source file.

The only other additional warning I get using the CLI is:

When running the CLI via tpai.exe myinputfile.png I get a lot of errors saying
Error | Could not setup auto model, maybe model file is missing?

Topaz Photo AI [v1.3.3] on [Windows]

Also posted same thing in the 1.3.3 thread Topaz Photo AI v1.3.3 - #4 by kevin.shank-0439. GUI set to enhance if you turn on “–showSettings” with CLI you see it is setting it to enhance enabled false despite getting the scale amount from the GUI.
Clearly a regression test failure, which is surprising because you would think they would use CLI for doing regression testing!

The fix for this will be in the next version of Topaz Photo AI releasing on Thursday. Please update to v1.3.4 and the CLI upscaling should work again!

Thanks, looking forward to it.

Could you also add regression or integration tests, to ensure that this doesn’t happen again? CLI functionality should be pretty easy to test with a set of prepared images and a set of CLI commands. Resulting output images can than be tested either against existing images or alternatively against expected output attributes (e.g. dimensions, etc.)

There should also be an option for the CLI to set these parameters. for instance --scale 4. This would make things much more useful.


Hello nrage2, the feature request Photo AI CLI - allow arguments to influence settings goes in the same direction, feel free to vote :wink:

–show settings can show what a parameter file could look like, but there needs to be a distinction between settings derived from auto or overiding the auto settings - so it is more complicated that it would seem.

I also the echo the comment about regression testing - these obvious failures would be caught before release.

I let the QA team know about this. We are working on automated tests including ones for the CLI so we can check functionality as we release updates. That will continue to be a work in progress.

We currently have a task in the roadmap for manual/custom settings in the CLI. I will bring it up in the team meeting. I don’t have a timeline yet.

An important note about regression testing, often companies do not want to do it with rapid development because it delays the weekly release. But what the lack of testing does is delays rapid feedback, bugs get released that make tools unuseable so users regress back to prior release, thus never feedback the current release, thus devs assume feature is OK and refocus on new features for next release. It does not matter if you fixed it internally the next day, because we have to skip the release and wait for the next release. Much better to give the release a day late.

Not just manual/custom settings but setting auto preferences, just like with the GUI auto preferences (which currently lacks denoise preferences)

verified working again in 1.3.4

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.