Photo AI 1.05 update/installation failed and all Topaz Labs apps disappeared

Today I worked with Photo AI 1.04
At the end I tried to update to the latest version 1.05.
During installation I continuously got an error message “unable to open internet connection”, although there definitely was a connection. Then the installation was terminated and suprisingly all Topaz labs apps had been removed from my computer (windows 10, 64bit, latest version 21H1 KB5018410).
I restarted the system, I deleted internet cache, I deinstalled all Topaz labs remaining parts and tried a new installation … no success.
Does anybody know a solution to my problem?

Just managed to install the old version 0.50, which does work. the old version mentioned before was not 1.04, but 0.50!!

I have been having that problem since version 1.03, and haven’t been able to get a fix. With that version, the download always stops at 67MB of the 69 MB download.

Clip

Same with me. Download of the install File worked find. The installation complained about the internet connection, while the connection is present.
At the moment I Lost my installation due to the rollback afterwards.
What can I do?

Same situation here with the Windows installer: 1.0.5 is uninstalled after pressing OK.
Is there any workaround without re-installing this version every d
ay? Thanks a lot.

I get exactly the same problem as everyone here with the 1.05 installer. 1.03 is o.k for me though. Is anyone at Topaz Labs looking into this do we know as it’s clearly a wider issue?

I have exactly the same problem

I have the same problem. I was able to reinstall 1.0.4. Hopefully, this gets fixed soon.

Same …

UPDATE

I uninstalled an app called IOLO System Mechanic today, and to my pleasant surprise I was able to install Topaz Photo AI 1.05 without any problems! The app is supposed to “Fix, Clean & Speed Up Your PC” and claims that it “Improves Internet Speed of your PC”, but this development indicates to me that it was probably degrading my network.

I had the same problem installing Photo AI 1.06, previously I had to use VPN to download the full installer to solve the problem, but currently the Photo AI doesn’t provide full installer. Does anyone know how to solve the problem or where to download the full installer?

I had problems with both Photo AI (same problem, VPN on/off, either install method). There is no problem with the internet; I had literally just downloaded it… I noticed its an .msi which is different to the offline/full installs from the rest of the suite. I also had major problems with Gigapixel, where it didn’t uninstall the old version properly and then the new version didn’t register either until 3 attempts later. WHERE CAN I GET A VERSION THAT ACTUAL INSTALLS? I’ve also noticed lately, that trying to run a software update from within any of the apps always fails, so have to uninstall old version, then reinstall.

I had the same problem. Managed to fix it by manually adding the .MSI to Windows Defender as an exception and allowed all connections.
Then installed without problem.