Parallel installation of VEAI v4.x and v3 and v2?

Currently I do have VEAI v3 and v2 parallel installed. I’ve read that v4 does remove v3, which I do not want to happen.
Before sending myself into a misery, can v4 be installed without affecting the other two and if yes, what kind of preparation has to be done?

Thanks for any advice.

Are you on the Mac or on Windows?


OK, there it is a bit more complicated and apparently could cause some problems due to the use of the same registry entries by different versions but still possible (as some people have reported to have concurrent instances on windows)

On the Mac all you have to do is rename the installed version before you install the newer or older one.

It’s a pity that Topaz always seems to make one step forward and two backwards in terms of usability…
Up to v3 parallel installations seemed to have no issues.

I’ve searched the forum before posting my question but haven’t found a definitive answer to this task.
If someone with experience of this on Win could chime in for clarification it would be much appreciated.

There are some people that did have more than one installation on windows and those seemed to work as well. So the Registry (and other settings?) thing might be more theoretical.

Maybe one with parallel instances on a windows system can chime in. Otherwise: simply try it by chosing an install path different to the standard for the additional install…

i am currently using many different version on the same computer, i am using sandboxie in order to do that, each version is installed in a different sandbox, by this way i can run different versions simultaneously without any problem.

do you not lose GPU processing when running in a sandbox?

it’s not a vm, you keep all the configuration of your machine, the gpu included, and all others software previously installed.
the only thing to take care are :

  • when you install topaz in the sandbox, configure the sandbox to accept msi token otherwise installation fails
  • authorise acces to some dir , where you will save the results, otherwise all you result files will be deleted when you close the sandbox
    there is a learning curve to use sandboxie, many parameters, but very useful !
1 Like

I tried using it now and when I run the topaz installer in the sandbox, the topaz installer detects I have another version installed on my computer outside the sandbox) and wants to uninstall it/upgrade. even though the topaz installer has the yellow frame around it indicating it is in the sand box.

yes, i’ts ok, as i said before, the sandbox see all the software and hardware you have previously installed, if you install another version in the sandbox it will detect an old version, and tell you to upgrade ( in the sandbox ), you can proceed with the upgrade. this will not upgrade on your disk, the upgrade will be done only in the sandbox.
then in the sandbox you will have the upgraded version, and out of the sandbox you will have the old version. everything you do in the sandbox don’t modify anything on your computer ( only the directory or files you have specified to retrieve your results ) .
even better you can run one version of topaz out of the sandbox and at the same time , the one you upgraded by lunching it in your sandbox ( yes 2 version running at the same time ).
on the screenshot below , you can see v1.71 and v3.12 and v4.2 running at the same time on a windows1O , the 3 have access to the gpu.


Thanks Denis!
I was thinking about using Sandboxie right before you posted those answers. That’s a very helpful advice.

I’ll give it a shot and see how it goes.
P.S. any reason why you are running v1.7.1? what advantage it has over the others? in what use case scenario?

in some very specific use case the first version of artemis works great when combined with sevral other models, processing using 5 to 10 models one after the other ( some topaz, some other brands, some created internally ).
it’s why i’ts important for me to be able to run and script processing with all the possible models from topaz, other brands and my own models running with python.

I have now installed VEAI v4 inside the sandbox - had to update my older Sandboxie version for the latest one, otherwise the installer always rolled back with an error message. But now it works.