Output EXR Options


Is it possible to change the output settings of EXR images? We usually work with 4K 16bit Half ZIP1 compression and each render usually has a size of 30Mb approx. Now we are using Topaz Video AI to rescale some old renders to 4K but when exporting the rescaled images in EXR we cannot choose neither output Bit nor Compression format and this causes that the 4K images size increase to 100mb instead of 30Mb approx.
Would it be possible to add in next versions of Topaz Video AI some output options for the EXR format?

Thank you in advance.

Topaz Video AI is not made to be able to handle all the additional things that can be stored in an EXR image. If you were to be able to output to exr, you would lose any such extras and only have the image left. Until it can deal with such additional things, you might as well output to PNG or TIFF.

Since raw 3D data is not part of standard released-to-the-public movies, and Topaz Video AI is not targeted at video creation, I don’t see it being a priority for many years. If at all.

I don’t quite understand what you are saying.

We are using Topaz Video AI to import HD EXR and export it in EXR 4K. Topaz allows us to import EXR and export it without going through any kind of movie. What I don’t understand is that if Video AI allows to read and write EXR why is it not possible to add simple compression options and output bitrate as it does in other formats. We are talking about simple EXR image without any extra layer information or anything strange.

Thank you for your response.

You can modify the encoders.json file to set the parameters how you need. (It’s usually hidden at C:\ProgramData\Topaz Labs LLC\Topaz Video AI\models on Windows.)
You’ll have to research what parameters ffmepg can take for exr.

I think that running exr files through TVAI will strip them of anything that’s not a single image.



I don’t have such file “encoders.json” nor even a “models” folder in the installation path or any *.json files at all.
I also checked in my workspace folder (where all the models …ox.tz files are) and no *.json file(s) exists.
please advise.

Are you on Windows? ProgramData is a hidden folder. You have to enable ‘show hidden folders’ in folder options. So far, you cannot change TVAI from storing the json files anywhere else.
I’m not sure how it is on Mac. I know someone’s posted it, but that was months ago. Maybe in one of the first three TVAI release topics.

I was looking in the Installation Directory, my mistake…