Odd Cropping In Studio 2

Whenever I invoke a Topaz plugin from Studio 2, it seems that the image is returned in a cropped state. This is driving me crazy! It seems to happen with either DeNoise AI or Sharpen AI.

I THINK it is an old crop I did on an early test image for Studio 2, and it is somehow being remembered. Does anyone know of a way to clear this so the sent image comes back as uncropped?

What is the image that you are opening, Project, JPG, PNG or TIF?

It is usually a tif, since that is what I use after raw processing in ACDSee Ultimate. I haven’t really kept score on that count though.

I usually process RAW in ACDSee, then send images to the ACDSee “Edit” tab (layers capable bit mapped editor), and invoke Studio 2 as a plugin. This doesn’t happen when using Sharpen AI and DeNoise AI directly as plugins.

It also happens when I invoke Studio 2 as a standalone and invoke the plugins.

I am not familiar with the external editor process in ACDsee, do you have a dialog where you can choose the type of image sent to the external editor? E.G. JPEG, TIFF etc.

If you do can you try a JPG/JPEG and send to Studio 2 and see if the crop is there after calling Sharpen AI or DeNoise AI from Studio.

If you can choose a TIF & settings it should be a TIF (no layers) with Alpha Channel to send to Studio 2. I am just wondering if ACDsee produces a layered TIF image.

If it doesn’t does your export dialog have something like this where you can respect or ignore crop?

image

Did you ever figure thus out as it’s happening to me too …

I just stopped using Studio 2, it doesn’t do anything special that I can’t do with other products.

Thanks for replying …. If denoise and adjust don’t function thru it it seems redundant …the support fellow confirmed those two are not intended to work with studio 2! First I heard of that !

I am having problems with Sharpen AI in Studio2 resizing or recropping my images. Workflow is Raw to DeNoise…Tiff to GigaPixel where cropped and enlarged to 6000px x 4000px…Tiff to Studio2 and 1st filter used was Sharpen AI…when Sharpen(output) was applied back to Studio2 my image had been resized…when I moved the Sharpen AI output slider I could see the image change…at 1.0 the cropped image was displayed; at 0:0 my original was displayed…at 0.5 an image that was a composite of the two images were displayed like the change was in progress. I decided to get a new input for Studio2 by using ACR and Photoshop 2021 to crop and resize to the values I used in GigaPixel and sent it as a Tiff to Studio2…when I ran the PS Tiff as the input, I ran Sharpen AI again and this time it did not recrop my original image. These errors never happen with the Studio AI prior to the 3.0 upgrades using the version of Sharpen AI that was part of the older version. The Topaz Help rep assigned to my error report after weeks of not finding any answers told me not write additions replies concerning my reported problem…he get back to me. I HAVE SCREEN COPIES OF THESE INCIDENTS!

Kat,

I don’t know why you were told that. I can open Studio 2.3.2 as a plugin from ACDSee Ultimate 2021’s Edit mode, and then from Studio 2, invoke Denoise AI 3.1.2, Sharpen AI 3.1.2, Adjust AI 1.0.6 and Mask AI 1.3.9 all as plugins from Studio 2, and they all work as expected.

Studio%202%20Plugins

In answer to @GlenBarringtonToo
I take a 4192 x 3264px .ARW RAW image from a Sony SLT-A57 camera, develop it in ACDSee’s Develop mode, including applying auto Lens distortion correction for its DT 18-135mm F3.5-5.6 SAM lens , and export it as a TIFF file. The TIFF file is still 4192 x 3264px. I can then open the TIFF image in ACDSee’s Edit mode, and invoke Studio 2 as a plugin. The crop tool in Studio 2 is greyed out (inactive) as expected, and after using a number of filters, the image returned to ACDSee and then exported is still 4192x 3264px.

I can also invoke Denoise AI, Sharpen AI and Adjust A as plugins whilst the image is in Studio 2, in turn being used as a plugin from ACDSee’s Edit mode, and the end image is still 4192 x 3264px.

The above is not my normal workflow, I’m just reporting that it can be done without any issues.
Since Denoise AI, Sharpen AI, and Mask AI can all be used as plugins directly from ACDSee’s Edit mode, there would normally be no point in accessing them via the Studio 2 plugin.
U2021%20Plugins

Intel i7-10700 CPU 32GB RAM
GTX 1660 OC 6GB Graphics
Windows 10 Pro, 21H1 build 19043.1052
ACDSee Photo Studio Ultimate 2021 (v14.0 build 2451)

Can you clarify what the output slider is you are talking about? I’m not aware of any output slider in Sharpen AI 3.2.1, only sliders for Remove Blur, Suppress Noise and Add Grain. Can you also clarify whether you are using a Mac or a PC?

For what it is worth, my Sharpen AI is not altering the size of the image, whether it is used free standing or as a plugin.

He means the Opacity slider …

Thanks @AiDon.

Setting the opacity slider of the Sharpen AI filter in Studio 2 to 0.00 should result in seeing almost none of the sharpen AI sharpening applied, 0.5 to nominally half of the sharpening effect being applied and at 1.0 the full sharpen effect applied.

Whilst there is some minor screen shift during movement of the slider at high levels of zoom (say around 450%) it shouldn’t, and doesn’t in my installation, alter the output size of the image, regardless of whether Studio 2 is used freestanding, or as a plugin (in my case from either ACDSee or Affinity photo).

I have found that if I do not crop and enlarge in GigaPixel ahead of Studio2 in my workflow the errors do not occur. I do not recall experiencing the errors in Sharpen AI until after the crop upgrade in AI GigaPixel. I am sending a detailed report of all my trials and finding including screencopies to my Topaz Help assigned contact. I have found also if I straighten a crop in Studio2, this causes errors/malfunctions during the Sharpen AI masking operations and I will be sending screencopies of this with my report to Topaz Help. It seems the opaque masking brush would be working on the original image while the transparent making brush would be working on a transformed and relocated image in the masking frame.

It might be worth mentioning that, although it works perfectly well for many people, none of the AI apps officially support being used as a plug-in to a plug-in and that’s usually when these cropping issues arise for some users. Topaz did try and stop the use of them as plug-ins to plugins but changed their minds and said they’d deal with issues on a case by case basis.