Not utilizing GPU at all

I just switched from RTX 3070 to 3090 and for some reason, Topaz Video AI stopped using the GPU altogether. And before you ask - all drivers up to date, I have CUDA and Cudnn as well, and the settings inside the app are set to use the GPU.

My CPU is good enoug has well, shouldn’t be a bottleneck. This wasn’t an issue with my 3070

Task Manager does not show true usage.
Use GPU-Z

1 Like

8 cores does limit the 3090, this is not gaming, its computing what we are doing here.

If it was using the GPU, there shouldn’t be a reason for the CPU to be at max
I agree the Task Manager is not that reliable sometimes, but personally it always shows me if the GPU is being used (I mainly do AI, not gaming)

Damn, really? That was my fear, I was hoping it won’t be true
For any other AI task I’ve done, it’s quite the improvement over my 3070 but oddly Topaz relies on CPU way too much…

If you have Hardware-accelerated GPU scheduling turned on it will not let you select “Cuda” in the dropdown box where “Copy” is.

Screenshot_20240109_231813

As you can see when you use copy it shows nothing being used yet the real usage under cuda shows
46% This is why i’m saying you don’t know what % your GPU is being used because task manager is not showing it.

1 Like

Does the new GPU appear in the AI Processor dropdown in Preferences? I recall we’ve seen some instances where installing a new GPU required reinstalling TVAI to get the app to “see” the new GPU.

Yes it does

Had something similar today with the new beta build. Reinstalling GPU drivers fixed it. No idea what the problem was.

Hey :slightly_smiling_face: have you ever tried with the studio driver from Nvidia ?

I’ve always used the studio drivers :grin:

1 Like

No other software uses the CPU for encoding or processing when you specified it to use NVENC and the GPU… but TVAI moment:
image
We will come out burning after this :speaking_head::fire::fire:

What do you see if you expand Utilization?

I have an export running now and this is what I get:

The second GPU on the list is the AI processor.