Not Enough video Memory (but I'm twice the minimum)

I am doing a trial of Sharpen and DeNoise (3.3.4) and Sharpen (3.3.1). I plan to use it for astrophotography, and images are sometimes large, including my current project (18269x12179).

I can open and process an image so long as I keep the previews VERY zoomed in, like 50-100%. I can save (watermarked) the results, it looks correct.

But if I zoom out, and all the time if I try to mask the image, I get a “Processing Error” and not enough video memory. The requirements say 2gb dedicated, I have 4. I have lots of ram (128gb) and a fast system (AMD 3970X with 32 physical cores, terabytes of NVMe and SSD drives, etc.). The GTX970 is the slowest part, because I still do not want to pay scalper prices. And it meets the minimum requirements and I do not care if it runs fast or not for Topaz, just if it runs.

But it won’t run.

I have variously set the preference to CPU vs GPU, to memory small and large, and the preview update not on auto (which does delay the message slightly but it still will not let me mask).

I do not CARE if it performs slowly – is there some way I can tell it to use less video and more regular memory? Are there other settings I can change?

Is it time to change your minimum requirements, or is this a bug?

The real problem is, if I buy this, and cannot use masking without buying a (scalped) video card, this is not a $100 or so issue but a $3000 issue.


Thanks, but (1) this is a user-to-user forum, and (2) why on Earth you need zoom out the preview? During several years of SAI and DAI use I just never did it, or felt the need to do that. Instead, I was always interested to see the result in different image areas at 100%.

I need to zoom out to mask off sections of the image to prevent sharpening areas not desired. If it were not for that need I would not zoom out (this is for sharpen really, I probably do not need it in noise).

As to it being a user to user forum, I submitted a support request also, but have not heard anything, and thought maybe some users here might know the answer. Yes, at the end I said “your” clearly meaning Topaz, so I definitely left a mixed impression. But a support request is also in. Being in a trial, not a customer, I do not know if I will get an answer, or how quickly, I have no experience with Topaz.

If there’s a better way to mask off areas to sharpen, please let me know. In my current case a galaxy occupies about a third to half of the area of the image, and I want it sharpened (notably inside it with the dust lanes), but when it sharpens the star field outside it is emphasizing optical artifacts rather than improving it.

I always use Topaz products as Photoshop plug-ins, apply them on a layer copy, and then put a layer mask between the treated and the original layers. Painting on this mask with gray/black/white brush helps to make flexible masking of desired intensity across different areas of the image and is non-destructive, therefore can be changed whenever i want.

1 Like

Hmmm… that might be a good workaround, did not consider it. Thank you.

I still hope they reply, so I can understand whether there is an in-product workaround/fix.

Please go to the Help menu and select Graphics info and then press Copy and paste the info here.

Application & Version: Topaz Sharpen AI Version 3.3.1
Operating System: Windows 10 Version 2009
Graphics Hardware: NVIDIA GeForce GTX 970/PCIe/SSE2
OpenGL Driver: 3.3.0 NVIDIA 496.49
CPU RAM: 130965 MB
Video RAM: 4096 MB
Preview Limit: 4431 Pixels

Interesting, the preview limit.

Try loading the latest NVIDIA Studio driver rather than the Game Ready driver and see if that makes a difference.

When I try searching it says “no certified downloads were found for this configuration”. Unless I’m searching incorrectly, I’m on their main driver download page and put in my setup.

@ivkuzmin, I used the layer approach and it looks like a good solution to the lack of being able to paint the mask in Sharpen AI. I went ahead and bought it and finished off the project on which i was working, but I still hope there is a better solution. Anyway, thank you for that suggestion.

Try here - scroll down to the AMD section…

1 Like

Great. I use the layer mask approach always as it adds much more flexibility to my work (i.e. non-destructive masking) comparing to doing the same in Topaz apps.

BTW, I still use DAI and SAI of 2.X versions in CPU mode because versions 3.X are too slow in CPU mode and still produce too bad artifacts in GPU mode.

Well, it’s not an AMD card, but I tried the NVidia card setting without impact.

So version 3 (despite being up to 3.3) has artifacts in GPU mode!?! I did mine in CPU just trying to work around this, but that is good to know (and a bit concerning).

Well… See my recent post in DAI 3.3 section related to some artifact observations.
My config is Win 10, i5-8400, RAM 32, GTX-1650 super, studio driver 762.

So I’m curious… I never heard anything from the ticket I opened with technical support. Does Topaz usually respond to those, does it take a long time?

The workaround of never showing a preview other than at 50 or 100%, then doing the masking in Photoshop worked. But I am still curious if there is a way to use the CPU instead of GPU, even if much slower, so it does not fail if I tried to mask in Sharpen AI? Or Denoise for that matter, though I have not yet bought it.

Is it typical for such questions to just be ignored? Was the question inappropriate in some way?

Topaz usually responds within 2 work days.

You can select the either the CPU or GPU(s)in Preferences, Performance.

Odd they haven’t in a week.

I selected CPU, no change, I don’t think it applies to the preview .