Models Download Script

Hi Suraj, whenever I try to run your script ffmpeg crashes several times in turn crashing Windows. Error messages are below. Please advise what is going on.


Description
Faulting Application Path: C:\Program Files\Topaz Labs LLC\Topaz Video AI\ffmpeg.exe

Problem signature
Problem Event Name: BEX64
Application Name: ffmpeg.exe
Application Version: 0.0.0.0
Application Timestamp: 64469d9b
Fault Module Name: ucrtbase.dll
Fault Module Version: 10.0.19041.789
Fault Module Timestamp: 2bd748bf
Exception Offset: 000000000007286e
Exception Code: c0000409
Exception Data: 0000000000000007
OS Version: 10.0.19045.2.0.0.256.48
Locale ID: 1033
Additional Information 1: b6c5
Additional Information 2: b6c57350c7c460c42e0fab80ca95b2fa
Additional Information 3: ef98
Additional Information 4: ef98f3aafc1389b3e77d5632daf3e24b

Extra information about the problem
Bucket ID: 1fe1f87746768a256c97050fa74716c5 (2060120919334393541)


Problem Event Name: LiveKernelEvent
Code: 141
Parameter 1: ffffac8e3a968050
Parameter 2: fffff80363960e60
Parameter 3: 0
Parameter 4: 3228
OS version: 10_0_19045
Service Pack: 0_0
Product: 256_1
OS Version: 10.0.19045.2.0.0.256.48
Locale ID: 1033

Script doesnt work for me. Gives me ffmpeg error.

It only worked when I edited it to specifically point at the FFMPEG binary in the TVAI folder. However, it takes a long time to run and I still only ended up with ~11GB in my models folder from a total of 302 files, not the >100GB that everyone else seems to be getting. I don’t know why that is. I’m running a laptop with a Ryzen 7 6800U CPU and Radeon 680M GPU. When I try to preview different configurations in TVAI, it inevitably wants to download the model despite making sure it’s configured to look at the same models folder I’m downloading to.

This is very frustrating!!! Model download is taking very long time…

Please provide a separate link for downloading the Models at a time…

Thanks

Really annoying to have to pay a lot of money for this software and not get the main models downloaded. Guess the company does not care. Definitely gonna try to get a refund

1 Like

Hello,

This script does download all of the necessary model files for every filter except stabilization. Is there a specific issue you’re seeing when using the script?

Can anyone get this script to work in macos? If I run this from /Applications/Topaz Video AI.app/Contents/MacOS I get an output similar to what others have had and nothing gets downloaded. Any help would be appreciated.
Running Ventura 13.2.1 on an M1 Mac mini, Topaz Video AI 3.2.5

Yea I am having ffmpeg errors like the others on this thread.

I tested the script for macOS and it doesn’t work. Why provide a script that obviously does not work and moreover without any detailed instructions. I am very disappointed with this version 3.2.7 and for the moment it is absolutely not worth buying until the version is at version 4. Version 2.6.4 remains for the moment better designed.

1 Like

I’m a Mac user and was running into the “Downloading Models” error. It seemed that every time I tried to generate a preview it would hang on that error and fail.

I wrote a PHP script that searches through the Topaz Video AI log files, regexes the missing models, then downloads them into the models folder. Any time I get that error, I just run the script and it pulls in the missing models. It’s been useful to me, so I figured I’d share in case it was useful to someone else:

To run, download the file, cd into the directory the script is located, and execute php getMissingModels.php from the terminal.

1 Like