Model file download failed

Gigapixel AI
I keep getting this message that model files need to be downloaded and every time the message comes up that the download failed. I’m stuck, the program will not work. Any suggestions? I did a speed test for downloading with my service provider and it came in at 178mb/s


Same here, looking for an answer.


I have a problem with downloading model files in Gigapixel AI. The problem exists with version 6.2.2. When I install the earlier version 6.1.0, everything works.
I disabled firewall and antivirus

Here is a message I have got:

Model File Download Failed

Model file downloading failed. Ensure you can connect to the internet.
Once confirmed, please temporarily disable any active antivirus,
firewalls, or other security software that could prevent the model files
from downloading. If the issue persists, please contact support.

Any solutions?


Same here … got the error message after upgrade to Gigapixel AI 6.3.2 … when will this be resolved? Software is useless now …


no change with 6.3.3 … any news?

Same problem here!


1 Like

Same. Irritating as hell-can’t use what I paid for

Same issue here, seems like there´s no fix done here

Seems like there´s no bug, but the “Buy new product” feature ¯_(ツ)_/¯

Topaz Tech Support, please respond to this thread. We can’t use Gigapixel 6.3.3, which we paid for. The Model Files fail to download. Please address this issue ASAP and provide a solution. Thank you.

Topaz is terrible. This could easily be fixed by allowing us to download the required files via a separate link on their download page.

They are crippling the old version to force you to move to Photo AI. Unfortunately, that product doesn’t upscale well at all.

1 Like

Just paid for an update and need for a client deadline. Now it simply won’t work without downloading the extra model files. Very frustrating. Tried everything but the download fails every time.


It’s now September 1st 2023. I too (as everybody here above me going back months) is having the same issue. are any of you on a Mac M2 chip? I have a Macbook Pro with the M2 Pro chip.

Please, try run topaz as administrator

And I just thought it was me. This is an unacceptable situation with software that as far as I can tell has not been officially deprecated or discontinued. Either support the software or tell us we are out of luck and we can all move on to a competitor.

Ok, this came from Topaz Support and it worked for me. Back up and running.

This is a conflict that we are aware of and working diligently towards solving. A simple workaround to alleviate this has been to delete the application, it’s plist files, and then reinstalling the app. Although this hasn’t solved the conflict for all, it has done the trick for most users. Please follow the steps below.

  1. Un-install: Open Finder > go to your Applications folder > Topaz Labs LLC. Move the entire Topaz Gigapixel AI folder, if there’s one, to the trash. Also, delete “Topaz Gigapixel AI” from your Applications folder if it’s still there

  2. Important: delete your ‘’plist’’ files of Gigapixel AI. For your reference, here is: How To Delete Your Plist Files.
    Note: Please restart your machine after deleting the plist files.

  3. Re-install

Also, if you use Lightroom and Photoshop please make sure that they are closed before installing. Once installed, please open Gigapixel AI as a standalone first before trying it with Lightroom and Photoshop.

1 Like


We should not pay for this stucking stuff!!!

Thank you so much! That worked for me…at least for now.

I went thru Topaz solution of uninstalling and installing again. It appeared to work until I needed another model download and I see the same issue.