Mask AI Stand-Alone Issue

Problem: After I save a composite image in Mask AI (as a standalone app), I am unable to open the image regardless of the location I save it. When I click on the image’s icon, I get an error message that this file is not recognizable & cannot be opened. I might add that I am using an iMac running OS 10.15.7 (Catalina).

I have corresponded with Topaz Labs regarding this issue & have not been able to get an explanation nor a work-around. Apparently this is not a common problem. Tech support created a ticket & sent my issue to their development team. That was about a month & a half ago. No resolution to date.

I am posting this hoping that there might be others experiencing the same issue. I would appreciate any guidance you might provide. Thank you so much.

What format are you saving the image in, PNG, TIFF, JPG, and if TIFF, what compression?

Have you tried saving to a different format?

I tried to save the image in all of the available formats. I also tried saving with & without compression. When I save the image to either my Desktop or to Lightroom Classic, the image appears as a blank icon with the selected format (e.g. TIFF). Cannot open.

The only option that seems to work is to use Mask AI as a Photoshop plug-in. I first export the image from Lightroom to Photoshop. Then I can launch Mask AI from within Photoshop. After I save the image in Photoshop, it will automatically return to its original location in Lightroom.

But, I want to use Mask AI as a stand-alone app. And Topaz Labs seem to have no idea why this won’t work. So I am hoping that someone has had the same issue & figured out a way to resolve it. Thank you.

I’m not a “Mac” user, but generally file save issues can be broken into some specific areas.

  1. An application can’t export to a location because that location is either protected, or there is a permissions issue. In these cases I would expect to see some form warning message when the write is attempted.

  2. An application actually exports a file to the chosen location, but that file doesn’t appear to be usable.
    (a) That can be that the exported file is zero length, or the file is corrupted, or
    (b) There are no applications “associated” with opening that type of file.

You could perhaps try to save the image directly to a USB flash drive rather that to your system disk. It it does save to the flash drive, but not to your system drive, it might point to a permissions issue.

Instead of clicking on the file, try opening it from Photoshop. It it opens from there but not when clicked on, it may point to an association issue.

Another option is to take a fairly small JPG, open it in Mask AI, remove part of the image and replace it with a simple solid color background. Save as a JPG and attach the exported JPG to a post in this forum.

Greyfox, thank you for the response. Although I suspect that reasons #1 or #2 above are doubtful, I will nevertheless follow through with your suggestions. The exported image from Mask AI cannot be opened even when sent directly to Lightroom Classic, where neither a permissions issue nor unrecognizable file would apply. However, I will post the results of following your suggestions. Thank you so much.

Something else to try. The attached JPG is a composite exported from Mask AI (Windows version).
Might be interesting to see whether it opens OK on your Mac.

Yes, no problem opening the JPEG whatsoever. I admit that I have not tried to save & open an image from Mask AI as a JPEG. In my workflow, I prefer to save it as a TIF in the event that I want to do some further processing in Lightroom.Nevertheless, I will still follow through on your earlier suggestions.

Thank you again.

Greyfox: Following your suggestions, here is what I discovered.

  1. As previously mentioned, if I export the image from Mask AI to my Desktop as a TIF, I cannot open it (for whatever reason). However, if export it as a JPEG to my Desktop, no problem opening it.

  2. If I export the image from Mask AI to my Desktop as a TIF & then import it into Lightroom Classic, again there is no problem opening the image in Lightroom Classic.

  3. If I export the image from Mask AI as a TIF to a flash drive, I cannot open it.

This suggests to me that my operating system is having trouble recognizing & opening a TIF file. This seems very odd. However, you might have inadvertently resolved my issue. My goal has been to export a composite image from Mask AI back into Lightroom Classic. Doing so as noted in #2 above accomplishes that.

Good that at least you can now use the TIFF files from Mask AI.

Actually I found a number of references to Mac Catalina users having issues with double clicking on TIFF images not opening them. Seems the default app for viewing them is Preview. The solution given is to right click on one of the TIFF files, select GetInfo, then go to the Open With section and change the default to Preview in the drop down menu.

There was at least one reference to Preview not being able to open specific TIFF files from an Epson scanner. Perhaps Preview isn’t able to handle specific compression types, but it should at least be able to handle non compressed TIFF’s or LZW compression.

First, in my last post I said that “if I export the image from Mask AI to my Desktop as a TIF & then import it into Lightroom Classic, again there is no problem opening the image in Lightroom Classic”. Well, this seems to work only randomly. Sometimes Lightroom can extract the TIFF image & at other times it cannot. Very frustrating.

Thank you for researching this issue for me. However, I am a bit confused. You are correct that the default Mac OS app for opening a TIFF is Preview. Then you indicate that if I right-click on the image & go to Get Info, I can then change the default to Preview. Do you actually mean to some other app other than Preview?

No, sorry for the confusion. It seems that when others haven’t been able to open the TIFF’s on Catalina , it’s been because TIFF’s are no longer for some reason associated with Preview, so the procedure given repairs or makes that association. I guess it could equally be used to make PhotoShop the default viewer for TIFF’s, but I suspect that might be a bit slow for general use.

I cannot imagine that Preview is no longer compatible with TIFF files. I can open any TIFF file except when that file originates in Mask AI.

The is unable to read DNGs created by Topaz products; this is a known bug and I have been given to believe that there’s no remedy. However, this is the first I have heard that there are problems with TIFs as well. I can confirm it to be the case with Mask AI, but not with DeNoise or Sharpen.
I suggest you report this is a bug and Hopefully it can be sorted out in the next update.

I have indeed brought this to the attention of Topaz Labs. I was told that they issued me a support ticket & forwarded my issue to the development team. Not having heard anything from them in about 2 months, I hope that the “development team” is not a euphemism the waste basket behind the building. Maybe I am being unfair.

I suspect that most regard this as a minor issue. I do, since the DNGs and the Mask TiFs do open in my photo editing software albeit not in Preview. However, the Topaz development team is pretty enthusiastic and if I am invited to beta test the next iteration of Mask AI I will try to remember to raise the issue.

Thank you so much. I realize that my issue is relatively minor & likely not a priority. In the meantime, I am exploring other options to open TIFFs that originate in Mask AI. Ultimately my goal is to use Mask AI as a stand-alone app & to be able to return Mask-created composite images back into Lightroom Classic.

I am not sure why you can’t start in LR, send the image to Mask AI as a TIF, process it there and then send it back again. But I am sure you have your own workflow…

I believe that to do so, Mask AI would have to have a plug-in in LR (which it does not). That sure would make life simpler. The only plug-in for Mask AI is with Photoshop.

Sorry to hear that. It might be because LR doesn’t do layers.