Mask AI Saving

Hopefully its all finger trouble but everything works OK until I try to save. It says I have saved but when I look to retrieve, absolutely nothing. I do a word search for the file by name but again nothing. When i use my old Topaz Mask 5 everything works like a charm. That is, it saves without any problem. Pray, tell me what I am doing wrong. AI has previously been saving just as you would expect. I only discovered the problem when I went searching for the file

When you go to save an image after your processing you should get a dialog like this where you can choose the type, file format, name and location. Open the folder where you saved the image and it should be there, if it isn’t check that you have sufficient permissions to save to that location:


Hi AiDon, Thanks for your prompt response. I tried again saving to another location and still the same result, nothing saved. As I indicated previously when using Topaz Mask 5 all saves to whatever location with no problems. I guess when all else fails I will have to delete/remove the file and reload from scratch. If I cross everything and with luck it will all work. Just as it had been since I originally started using the “free Trial” version and subsequent purchased. I live in Australia so maybe it’s all the fires and smoke in the air causing the problem. Goodluck and thanks again for your help.

1 Like

I can verify that the save as function is not working, at least in certain circumstances. If I open AI Mask in Photoshop CC (most recent version), make my changes in Mask AI, and then save it to a designated folder as a PNG file (without a background), it seems to work, but there is no file saved. I have lost all of my work.

In general, I have to say that the AI part of Mask AI is not very smart. For now, I’m falling back to Photoshop masking.

One more thing. After the “save as”, Topaz Mask AI closes, leaving Photoshop hanging because it is expecting a return file that never arrives. I have to terminate Photoshop with Windows Task Manager. If I’ve not saved my PS work before calling Topaz Mask AI, I either lose it or get it from PS recovery mode.

Doesn’t happen for me, I do a Save as and the image appears in the Folder, then I press the Apply button and it returns the mask to PS.

Are you using Mask AI via Photoshop ? At least one other person has had a similar issue who is using Mask AI as Photoshop plug-in.

I do not and have not had any saving file issues.

Yes when I use it via PS or Affinity Photo I don’t experience the problems you are facing. I would recommend though that you set the following preferences:


No I use all of the Topaz AI as standalone.

Just downloaded Topaz Mask AI. Using as stand alone (I am an ON1 photo raw user). Mask AI Program closes after any save. Have to make sure I save my trimask first so that I can reopen and then save with any background changes or as composite etc.