Mask AI Issues

I am not a moderator on the discussion board, but you raise excellent points in your post re: MAI ops & potential feature ‘tweaks’.

Could you copy the content from this post just above and also post it under the discussion board for Topaz Products > Product Ideas (that may not be the exact heading but I bet you can find it anyway). With the info posted there it might have a better likelihood of your suggested features making it to a product features user wishlist for “agile” development.

Topaz Products > Product Feature Requests
Thanks for the pointer.

1 Like

I’ve updated to the latest MaskAI (1.0.2), and aside from not getting the results I want, there seems to be a couple of issues.

I thought it was just me, or maybe my cheap mouse, but I would find when I’m tweaking a mask and clicking between Red/Green/Blue brushes, it sometimes didn’t seem to switch. This would result in me dragging a big RED line through my GREEN area, etc.

Well, I caught it. Here is a screen grab where you can see BLUE is selected, but my brush is still GREEN.

I have also found that holding down Spacebar in certain circumstances DOES NOT activate the PAN tool, again resulting in a color smear across the image.

While I’m complaining… :wink: does anyone else have issues with the range of the brush size slider? I generally end up working in the 5 px to 30 px range when tweaking a mask, and seldom much more than 100 when doing broad strokes/outlines. The slider adjustment in the 5 - 30 range is too finicky due to the small range of movement in the slider. So many times I’m trying to reduce the brush size a bit, and I end up at 1. I’m constantly overshooting where I want to be size-wise.

Maybe I just need to start using the shortcuts keys more, but if others find this a pain point, I would submit a request for something like a Range Toggle button that switches the slider range from 1-500 to 1-100. There may be other ways to accomplish this - just as a concept.

Yes, I’m getting the exact same thing with lines dragging across my image (& getting recorded on my mask). And I have tried working with my mouse and also with a Wacom Bamboo tablet & stylus. Same result either way. And CTRL Z doesn’t seem to work to let me step back to undo those lines (nor Delete key which works in that same undo way in Ps for Lasso Tools).

Also, the color shifting b/wn Brushes definitely lags. And the Brushes seem to function like certain selection tools in Ps that don’t turn off until you’ve completed a closed loop of marching arts (ex., polygonal lasso, or whatever).

The Panning function worked correctly once for me. Then I couldn’t get it to work again. When I press spacebar & drag, what kept popping up on different locations in the MAI 1.0.2 workspace is the short menu options list of the mask views (in a box) that can be displayed (cut, keep, mask) - unlike you, I was unable to grab a snip to show how it looks on my Win (7) PC using MAI 1.0.2 as Ps CC 2019 plugin. Oh boy, wait till Adobe Max next 1-2 wks and Ps CC 2020!

My brush sizes seem to span a size range I can work with, but the increments are not always the smoothest.

Tried installing 3 times now but even though the install completes fine, the program refuses to load… won’t even show me a splash screen.

Faulting application name: Topaz Mask AI.exe, version:, time stamp: 0x5ea21ab8
Faulting module name: cpu_extension.dll, version:, time stamp: 0x5d49f090
Exception code: 0xc000001d
Fault offset: 0x00000000000392f9
Faulting process ID: 0xaf4
Faulting application start time: 0x01d61ae4d2b837a3
Faulting application path: C:\Program Files\Topaz Labs LLC\Topaz Mask AI\Topaz Mask AI.exe
Faulting module path: C:\Program Files\Topaz Labs LLC\Topaz Mask AI\cpu_extension.dll
Report ID: a6b994d1-cb66-4992-8cdd-ba4f199f72cf
Faulting package full name:
Faulting package-relative application ID:

Last night Mask AI was very crashy for me. I mentioned it in the Paid Upgrades thread. The discussion was trending toward technical support, so I am posting here to keep the other thread on topic.

Recap: Mask AI kept crashing during Compute Mask with AI enabled, when processing one specific layer. It worked fine with another layer. Even when I isolated that layer into its own Photoshop file, it would crash. I exited and restarted Photoshop and tried again, Mask AI would still crash. GPU on or off, crash. It would not crash if I used Contrast instead of AI, but the Contrast results were very poor. I ended up using a different technique within Photoshop to mask that layer, then posted my minor rant in the Paid Upgrades thread.

So now it’s a new day. I decided I would try a few methodical tests to see if I could isolate it further before posting that image here for others to try. The plan was: put the layer in its own file (as I did last night), make sure it still crashes. Then reboot the computer (last night I restarted PS but didn’t try rebooting) and try again. Then try Mask AI standalone instead of inside Photoshop. Finally if it still crashed I would post the file here.

Result of the above: I put the layer in its own file in Photoshop, ran Mask AI plugin, and it did not crash. Tried it in the original file with all the other layers, it did not crash. I can’t make it crash today. Since last night I have not rebooted so it should still be close to the same state as last night. The main difference between last night and now is that last night Lightroom was running, while earlier this morning I had shutdown LR for an unrelated reason. So I launched LR, launched PS from within LR, Mask AI within PS (the exact workflow I did last night) and it’s still not crashing today.

I can only imagine Mask AI was crashing due to some issue with PS with how it uses the GPU or memory management. A few days earlier PS was doing some weird things that were resolved by restarting PS (although last night restarting PS had no effect). I am running the latest versions of all software: PS, LR, NVidia GPU Studio Driver on Geforce GTX 1070, Mask AI, Windows 10. I have 32GB RAM and monitor memory usage in Task Manager, the system was using less than 50% RAM at the time. There were no computer resource usage issues last night as far as I could tell.

At this point I don’t need any specific help, but you can see how frustrating it’s been.

TL;DR after sitting overnight the crashes stopped happening


Its driving me nuts over the last week I’ve rebooted re installed it works for an hours ( working perfectly last night ) today it asked me to re log in? why? and now its not working again…God knows what they had done to it but now it is wasting my time - I’m trying to do images for charity nut the frustration of this is making me want to stop doing them

I am staying with MAI 1.2.0 until I stop seeing consistent postings about crashes with the latest releases. I have projects I’d like to complete. If only for myself.