Mask AI and Wacom Tablet

I am among the LONG-TIME Topaz users who are disgusted by the company business model. That is, going back on your word, selling your product with the promise of lifetime free updates. The rationalization was that you needed the cash infusion to continue to improve your product. I am increasingly unhappy now that I purchased the “new and improved” only to have a non-functional piece of software.

Recently, Mask AI became non-functional for me. It turns out that there is a conflict between Topaz and Wacom. Topaz support stated to me that they do not support Wacom! Wacom is a mainstream product for retouching. I would think Topaz would be ashamed to admit this.

Instead they say: “you’ll need to unplug your Wacom tablet/mouse and use another standard mouse while using Mask AI. We have never had support for Wacom devices although some of our software versions may work with them. I wish I could have better news for you, but I’m afraid that our abilities are limited in this case as we don’t test with or support Wacom devices at this time.”

Just letting you know how the “new and improved for cash” business model worked out for me.

4 Likes

I can understand a Wacom tablet not working within some programs, but to have a conflict that stops Mask AI from working unless you unplug your tablet is absurd. I can use my Wacom tablet pen With Denoise AI without any problems. Topaz doesn’t need to test or support Wacom to find a solution to the conflict since they know it doesn’t happen in some of their other plugins.

When you say it became non-functional what symptoms were you experiencing?

I use an Intuos PT-S with the latest drivers, v6.3.42-2 and don’t seem to have any issues that cannot be fixed in the settings panel. Most important is to un-click Use Windows Ink on the Mapping panel as Intuos has a conflict with Windows Ink.

For me on Windows 10 & Intuos PT-S Mask AI is fully functional and many companies do not provide official support for Intuos or Tablet devices but they do work.

And your comments about the business model are uncalled for as it is purely speculation on your part.

I was a long time Topaz user, including Mask (since the Topaz programs were introduced). When I open Mask AI it simply closes within 5 seconds. There is no opportunity to change any settings inside the program itself. I was given some possible solutions by Topaz support: update video card driver, unplug Wacom. Updated driver did nothing. Windows Ink is not selected (never was). Unplugging Wacom worked. You read above the quote from Topaz support. They don’t offer further support for this problem because they don’t support Wacom.

As far as my comments being speculation, you are wrong. Topaz stated themselves why they reneged on their promise of free updates for life. Period.

Please go to the search bar and type in dxdiag and run the application. There is an option to save the output, do that and post the text file here. Make sure the tablet is plugged in at the time you run it.

Also, go to Mask AI and start the application then run Event Manager from the search box and see if any event is generated by Mask crashing. If there is, copy it and paste the info here.

Then unplug your tablet, open Mask AI and run Help-> Graphics info, press the Copy button and paste the info here.

I have been running AI Mask, DeNoise and Sharpen AI along with my Wacom for the past several months, all with no issues. Suddenly AI Mask crashes if launched as a standalone and freezes at launch from Photoshop. I was able to use with disconnecting Wacom but that is not a solution. With Wacom the de facto gold standard for a pen tool editing with photoshop, Topaz needs to up their game to make this work.

Just an FYI here. Wacom said I was running the latest driver yet a visit to their site revealed an update from January. Why Wacom didn’t flag my product as needing an updated driver is beyond me. Anyway…installed, restarted and all Topaz plugins are working. Fingers crossed it continues.

Could you tell me which driver you are using?

I updated to 6.3.41-1 in March with no luck.

Thank you.

PS.

This is on a Windows 10 PC
Intuos4 PTK-440

Yes and a PTK-540

Thank you.

You’re lucky. My “trial version” of Mask AI also crashed. Upon learning that there is a Wacom connection (and I am using a Wacom tablet), I launched my Wacom Desktop Center app, and clicked on Updates, to see whether I, too, had an obsolete driver. Turns out that my driver is up to date (but then again, I am using an Intuos 4, so, I wouldn’t really expect that there would be too many more updates from the time I bought my tablet).

Well, since I am using the trial version, hopefully, I have some “leverage” in getting somewhere (I can set a condition under which I will buy the software—if they fix the crash bug). :slight_smile: . . . . :expressionless: )