Many issues with v3.0.0 compared to v2

3.00 REVIEW:
So here’s the background: I was about to buy Topaz Enhance AI (v2.xx): Was trying it out for free, for like 2 months with the old version, and I was quite satisfied with the results. Just wanted to wait for black friday for a good deal. But now you guys launched the 3.00 version, which is +$100… (still -40$ compared to before with the “sale” going on… I understand that) and sooo… ofc I tried it out too… BUT unfortunately, I have to tell you, that it worsened my user-experience quite a lot… :frowning: I am now not sure anymore, if I still want to buy it.

So I took a lot of time to write down this stuff, I hope you take it as constructive critique:

For references, my specs are i7-10700K + GTX 1080 Ti, Win10.

  • Big bug: First couple of seconds of my exported video just shows a black frame (using H264 => .mp4). This is unacceptable. (never happened before, in 2.xx)

  • Ending a video prematurely/bug: When I click “Stop Processing” / cancelling: which is now strangely also quite hidden, (I loved the BIG button to do so in earlier versions), the exported file CANNOT be played… even if “ALLOW RECOVERY” is enabled. This was super easy to do in the old version… (for example to create big previews or if I decide that it just takes too long to process everything), and it always gave me a playable file.

  • Inconvenient, easy to fix: The app resets a lot of options to it’s defaults, which I don’t want. Even if preselecting in the preferences menu (which, honestly, should have more options too)

  • Still no WQHD support/preset: This wasn’t in the old version and it is still not in the new one. Do I really need to go to custom resolution and input: 2560 x 1440, everytime I want this, even though it’s a standard format!? (Pretty much all other video enhancing softwares have had this option for a long time). This should be SO easy to implement, from a coder’s POV… why is it still not here?

  • Worsened speed: I tried to recreate my settings from the older versions as well as I could, yet I still get like 20% slower fps, on the same files.

  • Inconvenient cropping: When cropping I can only use the mouse? (super inaccurate). Going frame by frame with left/right arrows doesn’t update the start/end timers anymore!!! (this thing worked perfectly before v3.00)

  • Strange default encoders / file formats: Standard for exporting is some encoder I guess most users never heard of and the standard format is .MOV? Who uses that anymore? Even when selecting H264/H265 encoders it defaults to .mov, whereas .mp4 would likely be preferred for like 90% of users, for many reasons (it is supported by HTML5 embedded video-tags, many video players struggle with .mov, while .mp4 is flawless, etc.)

  • Suggestion: When hovering over options, they should display a small explanation of what they do (Frame Interpolation, etc.).

  • Removed suffix options (filename stuff)?: There used to be an option to suffix the ending in the created file-name, which included the selected resolution (ie. 2x, 4x, 1920x1080, etc.). I really liked this, but now it doesn’t seem to be an option anymore?

  • Preview options: While I really like the new preview options, I don’t understand why they are displayed where they are. Why is it mixed with options for workflow. Place it in the top-right corner where it used to be or whereever… As it is, it feels out of place and has nothing to do with the things I actually want to the with the video (ie. cropping).

  • Workflow: There is so much unused (horiz.) space beneath the timebar. You are making software for clients that primarily cut/enhance videos, thus, chances are they have a big screen (at LEAST 1080p), responsive or not, these customers and their viewports should be yout main focus. The older version at least let you choose if you want time to be displayed in time or frames: My question is: Why not both?

  • Shortcuts: I found the keyboard-shortcuts for example for left/right-crop: But let me tell you, they are a pain in the *** (I’m using a German keyboard), why not make them customizable?


Have a nice day devs <3. As a dev myself, I know how crazy it is to make smth. like this. But still, there’s lots of things that are clearly a no-go, from a potential customer’s point of view.


I agree on all your points. They’ve jumped the gun on this one and released the new version before it was ready.

The only features that 3.0 has going for it is newer models. ( Please Topaz, backport the models to 2.6 )
Oh and 10 bit h265 encoding is also nice. ( Which tbh couldn’t be that hard to backport to 2.6 as well )
Everything else is awful.


Read the release notes:

Downloaded and installed 3.0. Am upscaling SD to 4k. Results outputs 2 files per file. One has the suffix the other has the tvai_mov suffix. Both are ABOUT the same size. Not sure why I get two file outputs for every file output. Can someone explain please?

You should post this on the main thread. Otherwise i do not think they will read you here.

The ‘tvai’ version was copied from the ‘chf3_dd3’ version. They aren’t exactly the same size because the software over allocates disk space while building the upscale. The larger the file, the smaller the difference in size (my 6GB upscales ARE the same size).