Issues with PSE 2020 & AI apps

I have been using topaz for years but never had as much trouble as I am now. Firstly I installed the Sharpen AI 2.0.5 and it doesn’t work with Photoshop elements 2020 it just throws up an error and crashes Photoshop E 2020 completely by shutting it down. In fact it doesn’t work at as a standalone either as when I try to save a file I get an error ever time. It all worked perfectly with the previous version The same on two different machines.
NOW I have just installed the latest Mask AI 1.2 which is the plugin I use the most and this doesn’t install the 8bf file into Photoshop Elements 2020 program preset folder so I have to create a manual shortcut to get it to work. Surely Topaz are testing these programs? I can only assume the same would happen with Photoshop CC. I uninstalled the previous version after I installed the new one so i don’t know if this is what buggered up the plugin shortcut.
To top it off I just installed the new Mask 1.2 onto my Dell Optiplex i7 12GB Ram Nvidia 2 GB GTX1030 card and it failed the GPU test in Photoshop Elements 2020 (after I had to create a shortcut in the Adobe Program presets folder once again)> So I ran the Standalone and the settings said the GPU was off. I then masked a file and all seemed to go ok until I saved it to a folder. The Saved tick came up in the screen but it actually saved nothing. Much like the problem with the sharpen AI although the Sharpen aI did report and error in red letters at the top whereas Mask Ai reported nothing just didn’t save. BUT I ran photoshop Elements again and it worked and applied the mask. So there are serious problems with these new plugins as all previous versions worked fine… Confused??? I am wondering if it is a permissions problem, maybe I should run them as administrator… I will try…
OK so I tried running as administrator and no difference still doesn’t save an image in standalone mode…

2 Likes

Exactly the same issues I am having. Denoise AI works OK as a plugin in PSE 2020 but Sharpen AI crashes the system back out to the organizer. Studio 2 also crashes the system. I had no issues with PSE 2018. I have sent a crash report - hope they can find a solution soon.

1 Like

I have sussed out my problem. I may be one of 2 things. If you are running AVG or Avast antivirus, they have created a new module under their “Computer” panel called “Ransomware Protection”… This by default protects the Desktop and prevents certain program accessing the protected folder. Just go into it and stop the protected folders you want to use. If this is not your problem then you may also find that the new Windows 10 updates also create “Controlled Folders”. You can turn these off as well. https://support.microsoft.com/en-gb/help/4046851/windows-10-allow-blocked-app-windows-security