Impression - Only Black Image Saved

Only black image when saved from Topaz Impression: Why is it so?m Hope anyone an help me and have a solution to my problem.

Usually this means either your GPU drivers are not up to date or your GPU doesn’t meet the required technical specs.

Please post the following information:

  • OS and RAM
  • GPU and dedicated vRAM

In the meantime, if you have a Windows PC, here is information on how to update your GPU drivers.

Having the same problem after a Studio update, now both Textures and Impressions output black. It all worked before! Updated my video driver but, same thing.

You really need to provide information about your computing environment … including the Video Driver version along with the information ask for above.

I have a i7 laptop with 16gb ram windows 10 which was just updated. Geforce GTX 960m GPU driver 384.76

Is your version of Impression v2.0.5?

Have you at least 1gb of dedicated vRAM memory?

Do you have dual GPUs on the PC?

Then go to the search/cortana box and type in ‘dxdiag’ without the quotes, select and press enter to run the application. When the app has finished gathering the info on the bottom right you will see a button to save the info to a text file.

Save that and then upload the text file to here. Note don’t copy the info into a reply just attach using the icon with a disk & up arrow.

Yes, x2.0.5 it is happening with Textures 2 also…newest version.
Has 128mb dedicated and 8gb shared
Seems to only let you upload graphic files. I do have the text file if you can explain how to upload.
Thanks!

Sorry, the file you are trying to upload is not authorized (authorized extensions: jpg, jpeg, png, gif, tif, tiff, tpp).

Hi,

Yes I see that will get @JoeFedric-TL to correct that.

In the meantime i have sent you a message with my email address, could you please send a message to that and attach the text file.

Well if I right click on photoshop and select “run with graphics processor” select high performance, it seems to work!

Ok give me 5 minutes and I will post instructions on how to set your PC to automatically use the NVIDIA GPU for graphics apps.

I would suggest you set your default GPU as the NVIDIA GPU by following these instructions, note that products that behave properly and don’t need the NVIDIA will select the integrated GPU, products such as word processors etc. Here are the instructions and a screen shot of the NVIDIA Control Panel:

Open the Control Panel, either by typing Control Panel in the Cortana box where it says “Ask me anything” or the same box which will have “Search Windows” if Cortana isn’t activated

  • Select Hardware & Sound
  • Select NVIDIA Control Panel
  • In the left pane, make sure Manage 3D Settings is selected
  • In the Right Pane select High-performance NVIDIA Processor from the “Preferred graphics processor:” drop-down list
  • Click the Apply button in the bottom right hand corner.
  • Then exit from the control panel.

Impression will run OK now as you have 2 GPU’s on your system of which the Intel HD Graphics is the default and it has insufficient memory to run graphics intensive applications that the NVIDIA, your other GPU, can. This selection will also improve the performance of other applications like Texture Effects, Studio & Glow, Photoshop or any RAW processors like Lightroom, Capture One etc., that you may have installed.

NOTE: You can select individual programs from the second panel (Program Settings) where you can allocate the NVIDIA GPU to selected apps rather than as the default.

Many thanks for the time you took on this! Back in business!

2 Likes

I’ve enabled .txt and .spx file types, to allow for Windows and Mac system reports. If we find a need to allow any more file types, I’ll look into it.

1 Like

THIS IS WHAT IS HAPPENING TO ME AND I HAVE TRIED EVERYTHING!!! I AM GOING TO FLIP OUT…I AM SO FRUSTRATED! ALL MY DRIVERS ARE UP TO DATE. IMPRESSIONS WAS RUNNING SLOW BUT WHEN I DOWNLOADED THE NEWEST PHOTOSHOP CC IT STARTED RUNNING SLOWER AND THEN ALL OF A SUDDEN IT ONLY SAVES A BLACK LAYER…WHAT THE HECK???

Angela,

First, welcome to the forum. It would help if you provided the system information Don specifies at the below link.

Oh, and your caps lock appears to be stuck.

1 Like

If you have dual GPUs also check that PhotoshopCC is using the correct one, it will be an AMD or NVIDIA and check that it has sufficient resources allocated.

I feel a bit like a dummy here. I am having the same issue the funny thing is if I crop my images impression is fine…very slow but ok. I haven’t used it with Photoshop yet. I love it and I’d really like to purchase it, however it has to work with large jpg. files (6000x4000) I have updated my Nvidia GeForce card and set it as my default card and I’m still getting black images. System info: Windows 10 64bit i7 2.7GHZ 8g RAM 512g SSD …it runs like a champ! :slight_smile: Thanks in advance for the help!
I have to add that it sounds like my pc is running hard to keep up with the program, weird since I multitask with PS and LR all the time and don’t have an issue.

This started happening to me in the middle of an editing session… it was working, then it suddenly started returning a black screen…

It will need the minimum technical requirements noted in this link. Especially take note of the minimum GPU requirements.