Import frame rate issue

Hi, I am experiencing an issue with what I think is a wrong frame rate. I have an image sequence of 940 frames rendered from 3Dmax at 15fps. I want to use Video AI to make this a 30fps sequence while maintaining the same video length and generating the new frames.

When i import my sequence it shows the whole video but says its only 535 frames or 37:10 seconds. 940 frames at 15fps should be 62.667 seconds.

I assume I am doing something wrong but cannot for the life of me figure out what it is.

Open the preferences and change the default image sequence FPS as it is most likely set to default which is 25 I believe.

image

Yeah, I already found that setting, changed it to 15fps and restarted. It correctly imports and says its 15fps but It still shows the incorrect number of frames/length of sequence.

One other note. If I ignore these issues and export, it actually will only export the 565 frames as if it is running at the correct 15fps. But only 565, not 940. So the output is roughly just the first half of my initial sequence.

Any other ideas to solve this?

Is there is break in the numbers around this frame?
Copy the generated ffmpeg command and post it here. That should give some insights.

No break in the numbers.
This is the generated ffmpeg for the preview:

ffmpeg “-hide_banner” “-t” “5.026666666666667” “-framerate” “15” “-ss” “31.04” “-start_number” “0” “-i” “W:/Interpolation Test/Molinaro 15fps 720/Molinaro_Stoney_Creek_Prominence_Animation_No_MGFX 2_%05d.jpg” “-flush_packets” “1” “-sws_flags” “spline+accurate_rnd+full_chroma_int” “-color_trc” “2” “-colorspace” “5” “-color_primaries” “2” “-color_range” “2” “-filter_complex” “split=2[out1][out2]” “-map” “[out1]” “-c:v” “h264_nvenc” “-profile:v” “high” “-pix_fmt” “yuv420p” “-g” “30” “-preset” “p7” “-tune” “hq” “-rc” “constqp” “-qp” “18” “-rc-lookahead” “20” “-spatial_aq” “1” “-aq-strength” “15” “-b:v” “0” “-an” “-map_metadata” “0” “-map_metadata:s:v” “0:s:v” “-movflags” “use_metadata_tags+write_colr” “C:/Users/teamneezo/Documents/Topaz VideoAI Projects/Default/previews/Molinaro 15fps 720_tvai.mp4” “-map” “[out2]” “-c:v” “tiff” “C:/Users/teamneezo/Documents/Topaz VideoAI Projects/Default/temp/_tvai_514530555/%06d.tiff”

“-t” “5.026666666666667” and “-ss” “31.04” should not be in there. -ss stands for set start and -t stands for time, as in how much of the movie to process.
Is this command from making a preview? I’m not seeing the tvai_fi filter being called.

I think i copied the text before the preview appeared, it took a while to show up:
ffmpeg “-hide_banner” “-t” “5.026666666666667” “-framerate” “15” “-ss” “31.04” “-start_number” “0” “-i” “W:/Interpolation Test/Molinaro 15fps 720/Molinaro_Stoney_Creek_Prominence_Animation_No_MGFX 2_%05d.jpg” “-flush_packets” “1” “-sws_flags” “spline+accurate_rnd+full_chroma_int” “-color_trc” “2” “-colorspace” “5” “-color_primaries” “2” “-color_range” “2” “-filter_complex” “split=2[out1][out2]” “-map” “[out1]” “-c:v” “h264_nvenc” “-profile:v” “high” “-pix_fmt” “yuv420p” “-g” “30” “-preset” “p7” “-tune” “hq” “-rc” “constqp” “-qp” “18” “-rc-lookahead” “20” “-spatial_aq” “1” “-aq-strength” “15” “-b:v” “0” “-an” “-map_metadata” “0” “-map_metadata:s:v” “0:s:v” “-movflags” “use_metadata_tags+write_colr” “C:/Users/teamneezo/Documents/Topaz VideoAI Projects/Default/previews/Molinaro 15fps 720_tvai.mp4” “-map” “[out2]” “-c:v” “tiff” “C:/Users/teamneezo/Documents/Topaz VideoAI Projects/Default/temp/_tvai_796913478/%06d.tiff”

Am I able to edit this ffmpeg text to remove the text that should not be there?

image
So here’s an image sequence I have. I set the input to 23.976 and the output frame rate to double that.
That enables the frame interpolation model.
image
Make sure ‘Duplicate frames Replace’ is unchecked. It does not, nor has ever, worked. Apollo is the best all around interpolator. You can try the others, but they’ll probably be worse.
After you have all that set open the export command:
image
You should be seeing the tvai_fi filter in there somewhere:
image

You shouldn’t need to edit the command at that point. Looking at the command I posted, it has a -t but that’s the full duration of the image sequence.

If you still want to edit and run the command for any reason, you can use that option two things up from the show command. That opens the command prompt or terminal with all the variables set that TVAI needs to run.

So this is the my export command

ffmpeg “-hide_banner” “-t” “37.66666666666667” “-framerate” “15” “-ss” “0” “-start_number” “0” “-i” “W:/Interpolation Test/Molinaro 15fps 720/Molinaro_Stoney_Creek_Prominence_Animation_No_MGFX 2_%05d.jpg” “-sws_flags” “spline+accurate_rnd+full_chroma_int” “-color_trc” “2” “-colorspace” “5” “-color_primaries” “2” “-color_range” “2” “-filter_complex” “tvai_fi=model=apo-8:slowmo=1:rdt=-0.000001:fps=30:device=0:vram=0.95:instances=1,tvai_up=model=prob-4:scale=0:w=1920:h=1080:preblur=0:noise=0:details=0:halo=0:blur=0:compression=0:estimate=8:blend=0.2:device=0:vram=0.95:instances=1,scale=w=1920:h=1080:flags=lanczos:threads=0” “-pix_fmt” “rgb24” “-q:v” “2” “-start_number” “0” “-movflags” “frag_keyframe+empty_moov+delay_moov+use_metadata_tags+write_colr” “-bf” “0” “-metadata” “videoai=Framerate changed to 30 using apo-8. Enhanced using prob-4; mode: auto; revert compression at 0; recover details at 0; sharpen at 0; reduce noise at 0; dehalo at 0; anti-alias/deblur at 0; focus fix Off; and recover original detail at 20. Changed resolution to 1920x1080” “C:/Users/teamneezo/Documents/Topaz VideoAI Projects/Default/previews/Molinaro 15fps 720_apo8_prob4/%06d.jpg”

The output was only 1130 frames. If I am inputting 942 frames and doubling, the sequence should be 1884 frames long. The last frame of the output matches frame 565 of my original input and matches the length of the incorrect preview from topaz.

You can try taking out the "-t" "37.66666666666667".
If that doesn’t work, you can try changing slowmo=1 to slowmo=2 and removing :fps=30 as well.
You probably need to output to an image sequence.