Gigapixel v6.1.0

www.topazlabs.com/learn/gigapixel-ai-v6-1-upscale-face-recovery

v6.1.0: Windows, Mac
Released May 11, 2022

Major Changes

  • New Face Recovery model - see post for details
  • Significantly faster processing on GTX 10, RTX 20, and RTX 30 series GPUs

Changes

  • Fixed black crop preview in large images
  • Improved wording of various tooltips/dialogs
  • Added slider to control face recovery strength
  • Improved blending around faces
7 Likes

Thanks!

Does the “significantly faster processing” also apply to RTX A2000 - A6000 GPUs?

When I see the significant improvement between 6.0 and 6.1 for the faces in the test images on the link above the downloads, I am OMG :scream:. I’m really looking forward to testing this improvement. It must be really great this cursor to refine more precisely the facial images. :open_mouth:

Face Recovery doesn’t work for me. If I turn it on, GAI doesn’t upscale my image at all and it says “Not Updated” in the lower left corner of the image. I tried with every model and with both GPU and CPU. Am I doing something wrong? I tried uninstalling and installing again from the full installer and it still doesn’t work.

My specs are:
CPU: Threadripper 3970x 32-core
GPU: GeForce RTX 3090 24GB
RAM: 64 GB quad channel
Windows 10 x64 Pro latest version

Both hardwares and system look fine. Please confirm the version is v6.1.0 based on texts beside top left log. Also, please go to help → install missing files, and see if it works. Otherwise file a case with the customer support team Topaz Labs

Yes I think so.

I’m testing this new Face Recovery model right now and it just leaves me speechless. Great job, guys.

However, there’s an issue with long-haired subjects, namely, just by looking at their hair, you can tell where the face-enhancing algorithm finished its’ job. This tool needs some sort of masking to make this face vs non-face border less visible. Or maybe Gigapixel just needs another model that would be capable of enhancing hairs and hair-like objects.

Bez nazwy-1

2 Likes

I managed to fix it. I had to copy the trgc folder from C:\ProgramData\Topaz Labs LLC\Topaz Gigapixel AI to C:\Users<my windows user>\AppData\Local\Topaz Labs LLC\Topaz Gigapixel AI. I think this is the same issue I’ve been having for a couple of years now where having a separate admin account on Windows messes up how Topaz software works and updates. I always have to manually do things after installing major updates or when installing it afresh. Can you kindly fix this issue?

Also another thing. Is it possible to improve the performance of model switching? Every time I switch between models or scale factors, I have to wait ~10 seconds before GAI even starts calculating the preview. It’s painfully slow considering the hardware I have. This was not the case a year or two ago, if I remember correctly. This is my biggest issue with GAI.

1 Like

Another issue: artifacts appear on the edges of the image when restored faces are located close to the edges.

2022-05-12 17-49-48.zip (213.5 KB)

I have the same quality on 6.1rtm and 6.1.0.6beta.

Another example…

2 Likes

Tried 6.1 and not that impressed. Took image reduced resolution by 4x. imported into GP 6.1 did a 4x enhancement with Face recovery and results aren’t great. I was hoping for better. but i realize its a difficult challenge and I would never likely get the results of the original again.

looking forward to next update.

why “Sorry, you can’t embed media items in a post.”

1 Like

The results are really impressive! Just tested here and wow, mind blowing! Congrats to the team!

Since the update I can’t download any needed files. Every time I try this it stops randomly afer som percent and says: Module file downloading failed. Ensure you can connect to the internet. If the issue persists, please contact support.

Any ideas?

Greetings, BB

Internet connection/stability issue? You should go to Topaz Labs and the team will pass you the files.

Hello.

No, internet works fine for me but thank you for your suggestion. I wrote Topaz Laps a message. Hopefully this will resolve the problem.

Greetings, BB

Hi,

I also have experienced such issues after upgrading. If, after a few tries, you still do not succeed, try a 2 image comparison view. Then subsequently compare to another model, and then that model will be downloaded. Since it only downloads part of all models, they usually succeed.

Cheers,
Bart

1 Like