Gigapixel v5.8.0

So, as there is an issue with downloading models, can we have a rolled-up file of all the models to download pretty please?

Actually forget it, it’s really bad visually (also very slow when trying stuff, but fast when saving???), I think I’ll go back to 5.4.5, alas… I’d post an example, but it’s not allowed.

Although as I downloaded 2.3GB of models to do all 5 versions I suspect people would like the model download. (I have the ability to temporarily do fast downloads, but not all the time.)

1 Like

Thats because of the shrinking Photography market.

The most of the people are photographing with smartphones.

And what we are doing here is a niche. (denoising, sharpening and enlarging).

Even most of the wedding / people photographers on Instagram don’t need denoising or sharpening software.

There is a trend coming that you photograph unsharp images as a style.

And most of the styles (presets) are Bohemian style with noise and one present color (red, dimmed green and blue).

Hi - it is a lifetime user license for the versions you own. We announced in February 2020 that starting in August 2020 that for each product out of the following that you already own Sharpen AI, Gigapixel AI, DeNoise AI, and Mask AI, you have a user license that does not expire and upgrade licenses that do expire in order to continue providing the best products and advancing features.

When you purchase any of our apps, you also get one year of upgrades included. At the end of that year, you have the option to purchase a Photo Upgrade Plan, which entitles you to another year of upgrades. However, even if you choose not to purchase the Photo Upgrade Plan, you still have lifetime access to the latest version of the app that is available at the time that your first year expires. You can also click here to learn more about our pricing policy.

We’re fully committed to enhancing our apps to absolutely get your money’s worth for them should you choose to upgrade. Upgrading is optional, however, so if you’re enjoying your current app setup, you can continue using that version for life. Your product license for the programs themselves is still in effect. As for the known issues listed above, they should be fixed in future updates in the near future.

If you have any further questions about that, please feel free to contact us (Topaz Labs) and we’d be happy to help.

1 Like

I have the same problem. PNG files with transparency get ugly edges.

The new face refinement models really work a treat - when they actually work. I’m finding that in a lot of images the face refinement is altogether absent, leaving behind a blurry face that doesn’t even have the regular AI enhancement - you actually have to turn OFF face refinement to get an improved image. Bug? Feature?

2 Likes

Hi - what you’re referring to will be addressed in future updates. We’ll probably be adding a button like in DeNoise AI & Sharpen AI so that you don’t have to manually click on the file in the list view in order to go back to the main editor mode or save the image.

1 Like

Hi Edwin - would you mind sending me some examples for this issue that I can share with the development team? It’d be great if you can send me the original images, a screenshot of the settings & models used, and the processed ones when disabling Face Refinement yields better results. You can send the files to my Dropbox below. Thank you!

Thank you - I’ll try to find a good example and send it to you.

Okay… done. I’ve included the original image and two screenshots. If you flip between them, you can see that the AI enhancement is applied identically in both, EXCEPT for the face area when refinement is on.

In previous versions I noticed that the refinement overlay would occasionally be drawn in the wrong part of the image, resulting in a weird ghostly face appearing somewhere unexpectedly. Is it possible that the refinement in this case has gone entirely offscreen?

I wondered if it might be GPU related (running on NVIDIA GeForce RTX 3090) so I switched to CPU mode and got identical results.

1 Like

Are you ever going to fix the default file name suffix being placed in the wrong location for single file upscales?

Single file: “-standard-scale-2_00x-gigapixel”
Batch: “-gigapixel-standard-scale-2_00x”.

It might seem a small thing but it drives me crazy seeing my file listings inconsistent and switches the order of files when I’m cycling through them.

Also a way to set the default Image Format in batch mode would be nice. Really sick of having to change it to JPG every single time.

1 Like

If I drag/drop a file into the Gigapixel icon, only APPLY IMAGE tab is shown. Where does my file go?

1 Like

Wonderful news, thank you.

Since updating to the newest Gigapixel I have the same experience…I can only choose Apply or Cancel. The Save button appeared one time, and saved the file with the adjustment specifics in the name. When only Apply is the option, the image adjustments overwrite the original image file. A new file is not created with the renaming specifics. I have not had this issue before. Am on a fairly new iMac with Big Sur.

Im not even seeing the original file being overwritten as the file dimensions remain unchanged. Using RAW files on an iMac, Big Sur latest version

I did some tests today and it seems that the new face refinement algorithm suffers from some childhood problems. What I observed is the following:

  • on some images, preview is more or less consistent with the output - that’s ok

  • on some other images, the preview shows enhanced faces, while the output looks like the ‘face refinement’ option was switched off - faces are highly disturbed, looks like the face refinement algorithm randomly stops working (?)

  • many times it happens that the whole image gets upscaled and enhanced and the face area is left unchanged

  • EDIT: in one case, the algorithm correctly refined two faces and completely ignored the face of the lady in the middle (see the files named ‘some faces are refined, some others are not’)

Here I attach all files I tested. I also added screenshots where there was a huge difference between previews and outputs.

https://drive.google.com/drive/folders/1FJATnnVWRUENGcTKfr87u4sDX7_8KT-h?usp=sharing

My system is:

Windows 10 x64 19044.1466

CPU: Intel(R) Core™ i5-7200U CPU @ 2.50GHz

GPUs:
iGPU: Intel(R) HD Graphics 620
dGPU: NVIDIA GeForce 940MX (using ‘game ready’ drivers)

Model downloading is switched on.

I tried switching from dGPU to iGPU and then CPU but that didn’t fix any of the issues I described.

3 Likes

Wow! Here’s what tentatively I’ve founds works for me regarding the Save Image button. I didn’t drag and drop an image into the icon, or the open Gigapixel window. Instead I chose Open Images from the File Menu and selected my file. The Save Image button was then there. After the adjustments I made to the image, it was processed and saved with the file name additions.

In Gigapixel’s preferences, do you have the location chosen where the files are to be saved? I don’t know what the default might be, but if you’ve not specified then the default could be where your files are. Just a thought…

Ken

Looking forward to the day GigapixelAI is migrated to the “drag-and-drop into Applications folder” format for Mac like DeNoiseAI, instead of that installer (InstallShield is it?).

Problem running post-install step. Installation may not complete correctly
Error running chmod -R 755 “/Applications/Topaz Labs LLC/Topaz Gigapixel AI”: chmod: Unable to change file mode on /Applications/Topaz Labs LLC/Topaz Gigapixel AI/Logs/2022-02-03-12-31-34-QML.tzlog: Operation not permitted
[[snip 20 lines]]
chmod: Unable to change file mode on /Applications/Topaz Labs LLC/Topaz Gigapixel AI/Logs/2022-01-30-04-21-44-Main.tzlog: Operation not permitted

((eye twitch)) I’m in my main admin account…

These are the strange pictures I now get when processing with the CPU and GPU after upgrading to version 5.8.0.
I deleted the program using Revo Uninstaller, made a clean install - the same result.
Updated the studio video driver to the latest version - the same result.
My configuration:
Application & Version: Topaz Gigapixel AI Version 5.8.0
Operating System: Windows 10 Version 2009
CPU Intel(R) Core™ i9-10920X CPU @
OS Windows 10 Pro 21H2 19044.1469
Graphics Hardware: NVIDIA GeForce RTX 3080 Ti/PCIe/SSE2
OpenGL Driver: 3.3.0 NVIDIA 511.65
CPU RAM: 65227 MB
Video RAM: 12288 MB
Preview Limit: 8000 Pixels


Forced to revert to version 5.6.1

1 Like

Count me as one of those who would like a downloadable bundle of all models.

5.8 is working very well for me. Considerably better than the prior version. Thanks!

1 Like

Hi! Thank you so much for the testing! Really appreciate the work.

I think I know the reason for your questions (2) and (3).

I tried your settings, and the software gives me the exactly the same output as your saved files. And this is actually expected: you set suppress noise to 0, which is not so recommended for many cases. If you play with the two parameters, especially suppress noise, you can see the results get much improved than setting them to 0 and 100. Turn the auto on can get you a decent starting point.

Now the question is, why your preview looks good—which is not the expected behavious.
Did you firstly turn auto on and then manually set suppress noise and remove blur to the values? If so, you need to press ENTER button to make the parameters take effect.
I think you probably did not click ENTER, but directly click the Update Preview button, and assume the preview is updated with the new entered parameters. Can you confirm it?

If this is the case, we would like to make change from our side to remove the requirement of clikcing Enter button. We will discuss it and possibly reflect this change very soon without having users to reinstall the whole software.

Regarding you question (4), I can get all the three faces correctly updated. Please help set the parameters correctly, and let me know if you still see this an issue. Thank you!

Just one question: can I download all the model files from somewhere? Like for VEAI.