Gigapixel v5.5.2

Yeah, same here. I’m not even sure what “Model Download” really means. Can someone provide explanation please. Why is it necessary to download almost 3GB program and than download a lot more for every image you are trying to upscale. Why is not the whole thing part of the original package when its that large to begin with? I don’t understand.

1 Like

Hi plug,

Did you run into this in the beta or just the release version?

This was because i disabled model downloading. Now it works… kinda. Clearly it works with low resolution and compressed - but at “standard” CPU and GPU look identical? REALLY identical - not a single pixel difference???

I tried downloading and installing twice, once from website and once from the email link. It didn’t seem to install either way. I’m running Big Sur V.11.2.

Hi all,

Here’s a quick explanation about the model downloading in this version of Gigapixel AI, for those wondering:

The AI engine architecture we’ve moved to necessitates a piece-meal download of AI models, as they don’t all fit in the installer (our installer framework cannot handle a size greater than 5GB). It is also not forward-compatible, as the number of model versions and number of model types grows in size, it is unrealistic to package around 100GB into an installer. Most users won’t use more than 5 of that.

The models are broken up into a few categories:

  • Based on selected model - Art & CG, Very Compressed, etc.
  • Based on hardware age - old hardware will use previous versions models (packaged into installer)
  • Based on output size - Each model has a 1x, 2x, and 4x version
  • Based on selected hardware in Preferences - CPU or GPU

There’s a difference between “Loading” and “Downloading”. “Downloading” is downloading the model it needs for processing from our model repository in the cloud. “Loading” is loading the model you have on disc onto the GPU. The “Loading” part is a performance bottleneck - depending on your hardware this could easily take more time than the actual processing.

It may seem like you’re downloading the model everytime you switch images, but if you change the scale and the engine sees that it should use a different scale model (1x, 2x, or 4x) it will switch to that model and download it.

We have plans to add the ability to download all the model in one shot from the application, but it was out of scope for this release. We didn’t want to push back release by another month or so just to get that in, as once you end up downloading the models from using the application you won’t have to download them again, even in a new update.


Reported for the beta, I did not yet try release version on Mojave due to new reports. Release version OK on Catalina, beta was good on Big Sur (haven’t installed release there yet).

To clarify, it was only the final beta that had this issue with Mojave, not the earlier one (if that gives a clue).

It’s not clear if for Windows, this requires Windows 10, or if it will run on Windows 7 and 8.1. (There is no “legacy installer” link.)

The “Minimum requirements” link from the download page says it will work in Windows 7.

Can a dev please explain what the model download does… is it now like Video Enhance AI, where it has to download CoreML, OpenVINO, and Open Neural Network Exchange formats in optimized block sizes? Users need to understand what is actually happening in order to insure everything’s working correctly.

1 Like

There is no legacy installer, there’s on installer for all Windows 7 - Windows 10.

+2 On the Mojave issue. Open downloader and it logs me out. Never installs.


I tested this new version, and very fast after model downloaded! I tried 2x and 4x sample, and just a few seconds on my hardware (i7-3770, 32 GB, NVIDIA 1660 6 GB). Fantastic, thank you @taylor.bishop and TopazLabs!

1 Like

For me everything else seems to work fine, but the produced images lose a lot of color. They are less “rich” in colors.


I’m a Mojave user and experienced the same thing as an_g. Important for me as I don’t intend on upgrading to a more recent OS. I have 32-bit programs that I still want to use.


Would you mind explain the definition of old hardware ?

I think everyone have different concept of what is new & old.
It would be great if you can provide the specification of “newer hardware”.

Put me down as another sad Mojave user who can’t update…

It takes ages to download the models because the program is barely using any bandwidth to do so. (3% max in my case).

Since their latest versions, both Gigapixel and Resize AI always open on the left of the screen, not where it was last used. This is a pain in the patoot when working with several photos and one wants access to the left of the screen. Can this be modified to how nearly all other Windows 10 programs work?

Right click the shortcut of “insert topaz product here” > Proprieties > Run > Maximised > Apply > Ok.

As a followup to my Mojave install problem (just like everyone else), I tried several times to update Gigapixel to v5.5.0 and it always “quit” the finder & “kicked-me-out” as the current user… I just now double-checked the installed version of Gigapixel and it’s cited as v5.5.0 even though it never appeared to successfully update! However it is terribly unstable – with any model selected & previewed, whenever I change to a different model or setting and then try to update the new preview the entire app with crash…

At this point I’d just like to get back to the previous version of Gigapixel until things are ironed-out… How do I download the previous version’s installer?

Same here. Have reported this with a support request to Topaz… Very disappointing there is no tech or sales support acknowledgment of a problem (however unreasonable such an expectation of responsiveness might appear). It’s reassuring, though not satisfying at all, to see this is not a singular problem on my device. Have already wasted 90 minutes trying to get the installer to work. I learned of the update because of an email they expressly sent to publicize it. Sorry to be critical, but it appears there was a slip, however small, in due diligence.
Ditto: MacBook Pro (mid 2018) running Mojave 14.6.3