Gigapixel v5.4.5

Download: Windows, Mac
Released February 25, 2021.



  • Idle CPU usage should be much lower on both Mac and Windows. If you’re not using the application but it is open, idle CPU usage should now be closer to 0%

v5.4.4: Windows, Mac
Released January 28, 2021.


  • Crash-on-close fix for certain MacOS versions, as well as the silent crash on Windows
  • Performance improvements, mainly for OpenVINO on Windows
  • Slight rewording of menu when in Plugin or External Editor mode
  • Fix “Previewing” tutorial opening the “Photoshop Plugin” tutorial instead of the “Cropping” tutorial

v5.4.3: Windows, Mac
Released January 20, 2021.

Major Features

  • “Art” model has been updated. This version removes color artifacting that occurred in certain images, and does a better job sharpening certain types of drawings / paintings / typography


  • Fix crash on closing on certain MacOS versions, and older versions of Windows
  • “Quality” slider has been reworded to “Compression” slider to better reflect its purpose when saving an image as PNG
  • Fixed colorspace off-by-1 issue

v5.4.2: Windows, Mac
Released January 14, 2021.


  • Tutorial for the crop tool has been added
  • Removed pixel cap when launched as a Photoshop plugin
  • When scaling above 30,000 x 30,000px, the zoom levels now change and are capped at 100%
  • Added “Ctrl+,” as shortcut for the Preferences dialog
  • Preferences, About, and Graphics Info dialogs now close when clicking outside of them


  • Fixed an issue that prevented some Windows 7 & Windows 8 users from using the software
  • Fixed an issue where custom prefix and suffix settings would not get added to the saved filename

v5.4.1: Windows, Mac
Released January 7, 2021.


  • Error text should now be aligned better in the Windows Photoshop plugin’s dialog box.


  • Photoshop plugin on Windows should now launch the application correctly
  • VR_RUNTIME_1.dll missing error should no longer happen.

v5.4.0: Windows, Mac
Released January 6, 2021.

Major Features

  • More robust and stable image support. CR3 files are now supported. Panoramic images, images that previously had issues in the application (crashing, unable to open, etc), are now supported. Note that there still may be issues with certain color profiles, file types, or images with non-standard metadata.
  • You can now save to the DNG filetype in the application.
  • In-App Rating System - if you’d like to help us improve our models, you can submit feedback about image quality with the smiling / frowning emoji in the bottom right of the preview panel.


  • Tooltips have been reworked to be more easily readable.
  • Preferences panel should now fit the application, even at the smallest window sizes.
  • AI model name now gets appended to the filename when saved out.


  • Minor UI fixes - no double scroll bars on the right-hand side, mouse cursor only changes when it’s supposed to when mousing over certain icons, etc.

Dear Taylor, I used Gigapixel 5.3 and it worked just fine. When I got the suggestion for updating to 5.4 I tried it, but now I feel sorry for that, because Gigapixel does not work anymore. I deleted the directory and the registry entrance, installed 5.4 twice but the sytem cannot find a certain runtime_1.dll… Now I try to reinstall 5.3. (after deleting history) Hope this helps… Greetings, Jan


Yes! Gigapixel 5.3 is working again! Probably I should stay FAR AWAY from version 5.4… Greetings, Jan

1 Like

Installed Gigapixel 5.4 and it no longer working with Photoshop 22.1.0 . When I invoke the plugin the message box appears telling me that I am invoking Gigapixel and then it just sits there without opening Gigapixel. Going to uninstall and revert to v5.3.2


1 Like

Hi Taylor & Adam,

I just downloaded/installed GAI 5.4.0 to my Win 10 Pro PC. Intending to use it as a plugin to Ps 2021 (22.0.1 rel. - b/c Adobe rolled me back from 22.1 several wks ago…). AMD processor (driver most current).

Several issues & a feature request for an upcoming gen of GAI:


1- I launched the standalone 1st immediately after install. The Preview Box view is still not filling that righthand space upon load of an image. A small square with subset of the image being worked on appears on that Preview view side. It only filled as it should and reflected the positioning of the wht Nav Box after I made a change to the upscale size amount (from 4x -> 2x).

2- The GAI Ps plugin would not launch from the Ps 2021 workspace (see the rel. I’m on noted above) via the Automate menu. I get the “invoking a Topaz plugin” msg box then it sits there and goes nowhere. Previous release of GAI worked fine. See snip from this new rel.

Features (or, How To if there…) Requests:
1- I’d like to see a “Settings Reset” (on/off) switch added to the GAI interface to the right of the AI Mode header. I would like to have all settings (from AI Mode & below) reset to “Off” or “0” (zero) when the switch is set to “On” and retain a user’s last-used settings when that Reset switch is set to “Off”. My expectation is that the Reset ‘on’ would set the AI Mode to Std.

2- Attached is a chicken snip (I had to very careful of my spelling on that…). I just Cropped this in the GAI interface (standalone product). I had 2 ‘challenges’ trying to do so. (A) It wasn’t clear that the Crop Handles were out at the edges of the image b/c they aren’t visible. They need to be a quite bright color to stand out. They were completely invisible. I thought the free-floating hatched thin lines overlaid on the image were the crop indicators & I wondered why I couldn’t move them. That’s not a great design… (B) Once I finally figured out the Crop Handles were at the edges of the image (where they should be) then I wanted to hide the 'Rule of 1/3’s" grid b/c I found it distracting and I’m not a slave to that method of cropping. How do we hide that Rule of 1/3’s grid if we’re more creative (or, rule-breakers) and don’t want that guide visible?

Just a heads up that the RAW file conversion gives all pixels not just the useable:

Therefore the ratio, which is 3:2, becomes:

A 5D Mk III image 5760 x 3840 becomes:

A 5DsR image 8688 x 5792 becomes:

And so on, etc. for 7D images, D850 and ARW images as well.

is the appended model name required ? i usualy just a ‘c’ for compressed

Downloaded and installed with any glitches. Opens up to initial red fox splash screen then goes black and nothing more.


Downloaded and installed without a problem (Windows 10). Runs OK as standalone, but as others have reported it doesn’t open from Photoshop. It’s also not adding the default suffix, although the add scaling mode function works.

UPDATE: It doesn’t add the default prefix either.

Downloaded and installed.

  1. It does seem rather slow - to 2x a 3264 x 4912 TIFF image running freestanding takes about 2 min 53 secs. That’s on Windows 10 Pro (20H2 build 19042.685), Intel i7-10700 Gen 10 CPU, 32GB memory, and a GTX 1660 with 6GB memory. Preferences set to use discrete GPU and Medium graphics memory.

  2. When I used it as an external editor from ACDSee Photo Studio Ultimate 2021 (manage mode), and clicked on Apply, I was expecting to get the export dialog so I could specify where the exported image should go.
    That didn’t happen, and without any warning it saved over the top of the original TIFF image without changing the file name (or adding a suffix or scaling mode). I’ve run that test several times with the same result. To me that is positively dangerous!

Downloaded and installed 5.4.0, but I get an error message that “The code execution cannot proceed because VCRUNTIME140_1.dll was not found. Reinstalling the program may fix this problem.”

So, I did an uninstall and then re-installed 5.4.0. I still get the same error message. It appears that something is wrong with your installation routine.

Please run Graphics info. from the Help Menu, press Copy and post the info here.

What version of windows are you using?

Hi Don -
As you can see from the provided screen shot there are no menus available. Just that blue border and the black viewing area. I can’t access anything at all. I’m running win 7 releaee 7601.

1 Like

OK, it could be that the latest libraries don’t support Windows 7. What GPU do you have? And if you have more than one is the high performance GPU allocated, for example if you have NVIDIA you would need to use the NVIDIA control panel to allocate to the app. Also make sure your drivers are up to date.

I’m reading here in the comments about a lot of bugs with Version 5.4.0. I think I’ll wait until they get acknowledged and fixed before I install this update.

1 Like

That is the way the external editor/plugin operates. The save as dialog is only available in standalone mode. All apps do this including DeNoise, Sharpen, Mask, GigaPixel etc.

It seems this version crashes every time at exit (works normally, as far as I can see, only on exit - boom), with no regard to the OpenVINO setting this time (before it crashed at exit, if OpenVINO was ON). I’m using GPU mode.
All that on i9 7940X, 64GB of RAM, RTX 3090, Windows 10 20H2, Studio driver 460.89

Faulting Application Path: C:\Program Files\Topaz Labs LLC\Topaz Gigapixel AI\Topaz Gigapixel AI.exe

Problem signature
Problem Event Name: APPCRASH
Application Name: Topaz Gigapixel AI.exe
Application Version:
Application Timestamp: 5ff73dc5
Fault Module Name: StackHash_9a8a
Fault Module Version: 10.0.19041.662
Fault Module Timestamp: 27bfa5f0
Exception Code: c0000374
Exception Offset: PCH_98_FROM_ntdll+0x000000000009CB04
OS Version: 10.0.19042.
Locale ID: 1045
Additional Information 1: 9a8a
Additional Information 2: 9a8ab9b79bbd6713e87a7552d1a67085
Additional Information 3: c8fb
Additional Information 4: c8fbe9fb1ff9dc3042753e626f1b2d78

Extra information about the problem
Bucket ID: 2c9feb223f9269abec113b4c800dac80 (2022462907417996416)

GAI v5.2 and v5.3.3.0b exits without this crash, when OpenVINO is OFF in GPU mode.
Could newest beta of Afterburner and RivaTuner Statistics Server interfere with this application?

In CPU mode with OpenVINO ON, GAI v5.4 became awfully slow, at least with generating preview., it’s like OpenVINO doesn’t even exist… I mean, it’s faster that OpenVINO off, but it’s nowhere near earlier versions, where CPU mode with OpenVINO ON was a viable option on 14-core CPU.

This crash might happen only after longer active OS session. Just now I didn’t encounter such crash in CPU or GPU mode with OpenVINO ON. I’ll keep observing.

Log files from the time of crash:

Its not a Win 7 issue, I just upgraded 5.3.2 to 5.4 and have the same problem on Win 10 Pro 64bit. Just rebooted to install 20H2 to see if that makes any difference.

Could you reinstall VC++ runtimes with, for example, this package? This dll you mention is from one of these runtimes.