GigaPixel Update

Just had a strange thing.

Opened GigaPixel and it told me there were updates, would I like to install. I clicked yes and a download started.

The download began and then stalled, about three minutes in, and locked up my screen. I waited but there was no movement for ten minutes so I had to do a hard re-boot.

After rebooting, I checked GigaPixel. It was still running the same version but when I checked for updates it told me that there weren’t any.

This is on a Mac running High Sierra.

1 Like

The latest version of GigaPixel is 1.1.1 and as for the download stalling and locking the screen that sounds strange so raise a technical support request on that part.


Coincidence or gremlins? My update appeared to install correctly but the software would not run. I had to uninstall, re-download and install again. Seems ok now!

Yup! I’m going through the same thing right now. Interesting that in the control panel it doesn’t show the program being installed at all. I went in there to attempt a repair and the latest version was not there. I’m going to uninstall using a third party uninstaller and then re-install it.

Problems, but different. FIrst off, after the automatic updater did it’s work, the new gigapixel would not run at all. uninstalled, re-installed, the program now runs but won’t register, keeps complaining of lack of internet connection, but that’s not a problem…I have tried multiple times now, and I think at this time 2:09 PM EST, Topaz’s server is having a problem. Sometimes I get an authentication message, which fails, most times it just comes right back and say’s the server is not responding.

Although this logging entry is suspicious:
2018-09-19T14:20:20.557 [Warning] <> QSslSocket: cannot call unresolved function SSLv23_client_method
2018-09-19T14:20:20.558 [Warning] <> QSslSocket: cannot call unresolved function SSL_CTX_new
2018-09-19T14:20:20.558 [Warning] <> QSslSocket: cannot call unresolved function SSL_library_init
2018-09-19T14:20:20.558 [Warning] <> QSslSocket: cannot call unresolved function ERR_get_error
2018-09-19T14:20:20.558 [Warning] <> QSslSocket: cannot call unresolved function ERR_get_error

Guys, it would be helpful for the rest of us if you state which system you are using, such as a Mac or PC. I’m delaying the update on my Windows 10 PC for now but haven’t tried it.

1 Like

Same problem with update running on Windows 10. Finally had to download installer, which uninstalled prior version and then successfully installed the v 1.1.2. This new version CRASHES A LOT.

I’m running Windows 10 PC with 32Gb RAM and nVidia 980 Ti and Quadro M4000 video cards on a HP Z840 workstation. So there’s plenty of processing power.

Prior versions of AI GPix were far more stable. Crashes occur primarily when I add additional files while processing is running. As I already said, prior versions had no problem with adding new files for processing.

Anyone else notice the reduced stability ?

I am running Windows 10 64 bit, latest updates, 16GB memory, GTX1050 video card. I had a few day old working version of the previous release. This system was just rebuilt two weeks ago as I had a boot disk crash. I still cannot register the software. I looked at the Apps list and there it’s listed as 1.0.9, yet the installer at web site clearly said 1.1.1 and there are no updates that the software finds for itself. I am uninstalling and trying again, clearly something is not right with the installer/updater on this release. Installer currently downloading the archive for 1.1.1. Ok, it authenticated me on the first try this time. So this is 1.1.1, don’t know where 1.1.2 came from but it’s not there now.

My apologies the latest version is 1.1.1 as you can see from the changelog …

I have a Mac running High Sierra, I did the latest version 1.1.1 update maybe a few days or week ago and have not had any problems.

My app upon opening told me there was an update to 1.1.2. The update has now disappeared but not before it locked up my computer when I went through the prompted procedure, which is why I raised question. Looks like others have had the same problem.

1 Like

I did not get this update message when opening GP or when checking updates… this is very strange that it happened to some and not others?

This definitely needs to be brought to the attention of the Topaz team and that they be aware of this.

That worked. Uninstalled it and then went to the Topaz website and downloaded the current file.

A post was split to a new topic: AI GigaPixel - Keep File Suffix Between Sessions

I see that 1.1.2 has just been officially released so I guess it’s time to close this thread. I presume my experience was down to a pre-release test error by Topaz.