GigaPixel Changes Hue

GigaPixel Changes to Green Hue… No different what I set to in Profile settings it comes out to the same hue. It is the latest one that I just downloaded may 27, 2019
It looks if I use 2x then is OK but 4x and higher changes




I’ve done several enlargements at 4x and 4.3X and haven’t seen any color shift. (Win 10 PC) AIG v4.1.1

Please raise a technical support request at the Topaz Labs website.

I have seen this with the Max Quality Models turned on, but not with Max Quality Models turned off.

It’s no different what settings I have it shows right away green hue. I have the same problem on two computers.
One is laptop and the other one is a Gaming computer.

Forgot to say that both my computers are windows 10 and fully updated with all updated drivers.

strong text

1 Like

I have EXACTLY the same problem too! In addition to the horrible green hue which makes the image look sick and lifeless, I also get horizontal banding like a bad TV signal on an old vacuum tube TVs and the whole image is overall blurry. Also, when I use CPU mode (since historically it’s always produced higher quality upscales than GPU), I get a nasty gritty/rough canvas paper-like texture all over my image while version 4.0.2 was silky smooth AND detailed at the same time.

All in all, the new versions of the whole AI suite have been a total disaster. Image quality regressions in Gigapixel (both GPU and CPU mode), COMPLETE inability for me to use Denoise AI anymore after I updated it because it crashes every time I try to load my image. :angry: I reinstalled the programs, tried different drivers. Nothing helped. Does anyone even test the software before pushing out new versions to customers? I wouldn’t be that angry if there was a way I could revert back to the older versions. The installer program automatically downloads the latest versions which are inferior to the older ones and even outright BROKEN in the case of Denoise AI 1.1.1.

1 Like

@joe.Bejm If you want to post a larger version of your picture, I will try it on my machine. I’m using a Ryzen 5 2600X CPU, 32 GB RAM, Radeon RX580 video card and Win 10. I just tried another jpeg picture enlarged 6X with Max quality turned on and off. There was no color cast or shift and it even removed some jpeg artifacts.

Also, I have Keep color Profile set to yes.

There is something with color palette in this picture that Gigapixel does not like.
I try some other pictures and some I have a normal but some I have a green tint that you can see it but not as bad as this picture

This is the original…

Joe, I ran the image and if the max quality model is set to no in the Preferences there was no color tint. However, as shown below, if it was set to yes, the preview show a definite green tint. I think this info should be sent to Topaz with the picture.

1 Like

I just let Topaz know and gave them information plus link to this post.

Other thing what I found out if you have set to “NO” and restart the program then process the picture there is no tint and if you change to Max and process the picture again then picture will not have the green tint until you will restart the program.

1 Like

I hope that what we posted here and your input gets this fixed.

I hope so too…

Thanks Joe. This needs to get fixed!

1 Like

Joseph & Ron,

I’m also getting the color tint/shift when Use maximum quality AI models is set to Yes, and not getting it when it is set to No.

What I can’t confirm however is Joe’s “Other thing what I found out if you have set to “NO” and restart the program then process the picture there is no tint and if you change to Max and process the picture again then picture will not have the green tint until you will restart the program.”

I set it to “No”, restart the program and process the picture. There is no color shift/tint. If I then change it to “Yes” and reprocess the picture without restarting the program, the color shift/tint is back.

The other thing I noticed, is that when it is set to “Yes” the color tint/shift is present in both a jpg format output and a Tiff format output, but there is a difference between them. That also doesn’t seem right


I did not put the output formats because in preview it self you can see the Green Tint so if you save it then then the green tint will be save.

This is what happens to me as well but as my example shows and Joe mentions, the preview shows the green tint without the need for processing (max quality mode). I think we have shown that the issue is somewhat independent of hardware and OS.

I have the solution, even it’s not the best one.
Just uninstall the actual version 4.1.2 and download the 3.1.1 (thanks to Artisan West for the solution)

Examples :

source image :

4.1.2 with hue (green) problem :

3.1.1 (expected result) :

1 Like