Gigapixel AI - Update running extremely slow

I’m an early user of Gigapixel AI. I received an email notice regarding an upgrade today and am attempting to install the Version 4.1.2 update. It’s been running for about 1 hour, 45 minutes and is only at 11% complete. Do I cancel the install and start over?

New info 7/19/19:
The issue is with the un-installer. This is the piece that takes hours. I let it run all night. It appeared to be complete this morning, but when I attempted to load the new version it said that a previous version was still on my machine. It re-started the un-install program. The second run of the un-install program is once again going extremely slow. At 9% complete after the first 30 minutes.

It took a while to download for me but the actual installation process was pretty quick, I think. I would try again…


I installed the Gigapixel AI update today without any problems, but my update says it is 4.2.0 not 4.1.2 ??

I was going by the version number provided on the main screen for the download page. Since my installation is incomplete / failed, I’m not sure what version number is recorded in the program “About” info.

Mike @MikeRogers

I don’t recall reading of an “uninstaller” taking hours to remove a program!

Can you please be more explicit:-
Mac or PC?
The programs own “unistall” function?
Or a 3rd party uninstaller?

A little bit more info will aid those with more specific knowledge to advise you :slight_smile:

PS the last (fully stable) version was 4.1.2 but the newest update is apparently 4.0.2 released I understand on 17th July.

I too have just updated to the latest AI Gigapixel v4.2.0 & find it extremely slow whilst processing. ’
I also updated Denoise to v1.2.0 & find it very slow whilst saving. Also found a heavy colour cast on the completed photograph
It would be really nice if we were given the option to save these updates so we can revert to the last working update, as it sits programs are just updated as we open them
Thanks guys, still love the programs.

Hi Derek @heronwell

I agree about downloading in readiness and for possible overlay installs of older more ‘stable’ versions.

Having said, that the programs IME don’t auto update, I have to make an active decision to update and I typically wait to see & read of any new updater user experiences :wink:


Windows 7 Pro Service Pack 1, all updates done

Using whatever uninstaller started when I clicked the update link from the Topaz website.

The uninstall program progress bar now says 100% complete, but buttons at bottom of uninstaller window aren’t active and if I try to to close the window it asks if I want to stop the action.

When I go to “Programs and Features” in Windows 7 control panel, Topaz A.I. Gigapixel no longer shows up. I also no longer have icons for the program in my Start menu.

The Topaz A.I. Gigapixel folders are all still in place on my hard drive - most files dated 12/4/2018.

It appears that the uninstaller did not work with my version of A.I. Gigapixel and/or my version of Windows…

Not quite sure what to do next. Half tempted to delete the folders on my hard drive, but not sure what has been left lingering in the system registry or other locations. Very frustrating experience.

Thanks for chiming in. I wonder if anyone with Topaz monitors the Support forums?

I opened an official trouble ticket with them earlier today, but no responses yet.

I’ve always gotten answers back from them, but sometimes it may take a few days. There are a lot of Topaz product users.

1 Like

When updating one of the programs you will get a 100% green bar and the word at the bottom will say “Quit”. The installation is not complete but there is a long pause where it looks like nothing is happening. Do nothing at this point as it will take several minutes in some cases. Then the installer will ask you if you want to install (Install button). Click that to continue which generally goes fairly quickly.

Hi Mike @MikeRogers

I am still a tad puzzled by your refering to an “uninstaller” as I have never seen it mentioned on the website in the manner that you talk about " Using whatever uninstaller started when I clicked the update link from the Topaz website."

All I can see is the online installer!

Though drilling into the site I did discover an offline installer here Topaz Labs

You have expand the questions tree at “Offline Installers” and the one there to download is for v4.1.0 (this is from May 2019)

I return to my original insight that I have always updated from within the program itself and that ‘simply’ does its thing…and on my ADSL connection takes approx 30mins to download the components and the I, as I recall, have to click to install it and off it goes and it installed in a few extra moments.

I do hope you can get a resolution and find some harmony with what IMO is great bit of software.

PS FWIW I run W10 v1903 (v1809) Pro 64 Bit and AIG is v4.1.2


I got a response back via the help desk. I ended up deleting the program folders manually after the uninstaller finally finished. All that the uninstaller removed was the icon in my start menu and the program from by Program and Features area. After removing the folders I restarted the computer. Next I downloaded the offline installer (help desk gave me a link to that). I attempted to run the installation program but ran into issues where it gave me errors saying that it couldn’t write to the newly created folders that the installation program had just created. I stopped the installation, manually deleted the two folders created, restarted the computer and turned off my firewall.

I tried again and got an out of memory error. I have 16GB of RAM plus 8GB on my video card. I passed this info on to the help desk with some screen captures of my system information and video card information.

Hopefully we will get this going. The program ran fine earlier, I was just trying to update it because the newer version was supposedly faster with some improved features.


@MikeRogers Mike, you are certainly being tested. I have updated all but Gigapixel with no problem. I’ve been hesitating with that one due to some comments here. I hope they get it fixed for you.

Has anyone else updated Gigapixel and tried it? Is it much slower or producing bad results? My results with Denoise AI are consistent with previous versions in that Denoise is best for low to medium noise and AI Clear (in the Denoise app) works well for high and medium noise.


You asked “Has anyone else updated Gigapixel and tried it? Is it much slower or producing bad results?”

I have updated Gigapixel AI to 4.2.1.
Whilst I didn’t record any “time taken” for specific test images on previous versions, the times the current version is taking, which vary of course with the specific upscale, doesn’t seem excessive.

I’ve not run into any significant issues on the images I’ve processed with it to date, but I should point out that they have all been either TIF or JPG.

@Greyfox thanks for the input. I may upgrade then. My GPU usually handles gigapixel reasonably fast but as you say it depends on the scaling. I also use mostly jpg and a few tif files.

Update: I ran a test using a 4912 x 3264 pixel (16Mpx) jpg file (2x scaling) with version 4.1.2 and the new version 4.2.1. The processing time was identical. Afterward, I opened both pictures in Affinity Photo and could not really see any difference. While the picture i used was a long distance shot so it wasn’t very sharp. I don’t see any problem with the latest version of Gigapixel. My time for both was 2 minutes and 9 seconds.

I got some additional help from the support folks. I was logged in to my system with administrator rights, but still had to right click on the installer program and choose “Run as Administrator” for it to work with no “Out of Memory” errors. Installation went smooth and its now working. Everything appears to be ok now. Thanks for all of the advice and support.