Gigapixel 7.0 download error

Basically I was in the process of installing gigapixel’s latest update - 7.0. And then it suddenly told me my network was unstable and that it was an error. The next thing I saw was that it finished the installation wizzard without finishing the installation completely… So I was a little worried if everything would be ok. And so I tried upscaling a high quality picture it it just told me there was an error loading the model…

Let’s perform a fresh installation with the steps below:

  1. Delete the Topaz Gigapixel AI folder from the default installation path - C:\Program Files\Topaz Labs LLC\Topaz Gigapixel AI
    Note: If you didn’t install Gigapixel AI in the default installation location, it will not be in the path above.

  2. Open the app Registry Editor on your machine and delete the Topaz Gigapixel AI folder from the registry below.

  • HKEY_LOCAL_MACHINE\Software\Topaz Labs LLC\Topaz Gigapixel AI
  1. Download a fresh installer for Gigapixel AI v7 from our Topaz Labs Download Page.

Um, I closed gigapixel AI, and when I opened it again and tried upscaling the same picture it prompted me to download the rest of the models. So now they’re downloading.

Just wanted to check back and see if your model installation conflict was resolved.

oh sorry for the very late reply. I managed to download everything without issue now, but I’ve run into a new problem…

What is the new conflict you are facing and what version of Gigapixel do you currently have installed?