Gigapixel 7.0.2


This week we have another patch that should fix various issues. One of the bigger ones is that all faces should now be selected when Face Recovery is on. There are also a handful of metadata fixes as well as an update to ExifTool.

As a note, all pre-7.0.0 versions of Gigapixel will upgrade through 7.0.0. This means if you’re on 6.3.3, the in-app upgrade flow will take you to 7.0.0, and then you can see 7.0.2 from that version. You may optionally also download the installers directly from this thread. They should automatically uninstall Gigapixel 6 for you before installing the updated version.

Released February 14th, 2024
Mac: Download
Windows: Download

Change log:

  • Updated ExifTool from 12.69 to 12.76 (ExifTool Version History)
  • Added warning when upscale goes past 6x
  • Added Close All Images option to right click menu
  • Changed default suffix to -gigapixel instead of -topaz
    • This change only affects new installs
  • Changed cursor when hovering navigator to a +
  • Changed color of Lines model to make it look less like an error
  • Changed how thumbnail orientation is handled to fix some edge cases
  • Changed icon on the login success page
  • Fixed issue where not all faces would be selected for face selection
  • Fixed WEBP images not getting image dimensions from metadata
  • Fixed wrong file being highlighted in explorer/finder after a file name conflict
  • Fixed arrow keys being able to navigate past the end of the imported files
  • Fixed orientation for some older Canon files
  • Fixed export options sliders not updating until released
  • Fixed issue where deselecting current image deselected all images
  • Fixed issue where save statuses were updated for the wrong image

1 Like

The change from v 6.3.3 to 7.0.2 is absolutely awful!
What a mess! The crop function is broken and does not allow to select the desired portions of the picture correctly and there are no more side by side views in 4 frames to compare the various models.
On top of that, then after finally deciding on an optimum AI model to use going through a truly horrible workflow because of not being able to compare the results side by side, the image processing is ridiculously slow (on an AMD Ryzen 5 3500U with internal Radeon Vega 8 graphics and 20GB RAM). It feels like it literally takes more than ten times as long as it took in v 6.3.3 to process an image.

I have only tested upscaling a couple of images to compare with v 6.3.3
I very much do appreciate the new AI models standard v2 and high fidelity v2 which do seem to create better results, but other than that V 7.0.2 appears to be a complete disaster and truly makes the new Gigapixel AI version almost completely unusable for me.

It’s an absolute pity considering how well and how fast Gigapixel AI v 6.3.3 worked overall (despite a few minor issues)!
For the time being I will most likely decide to go back to version 6.3.3 which may not produce quite the same results but at least works and allows me to see and compare what I am doing. I guess I will just have to wait and hope for a significant update to come soon that fixes all these horrible issues with v7.0.2. that so many people are complaining about here in the forum.


Like mentioned above, why this main Problem with „Processing twice“ has not been fixed?

We use GigaPixel for commercial Purposes, and the twice Pocessing takes extremely more Time, and we have no Time to wait on every Upscale… :rage:

I don’t understand why others find it slower. I scaled an image from Photoshop and it was very fast. +/- 2 seconds. But the image was a little larger than 1K. And it was a x2 or x4 scaling. I also had Topaz Video AI running in the background.
But I also have an 8GB RTX 3070 combined with 32GB and an Intel 9900K I9.

An image as small as 1K will never take very long. Try processing something larger and compare version v6.3.3 to v7.02.
I tested a large image I had previously upscaled in version 6.3.3 (with processing only taking a few minutes) just to compare the results of the new model with the old result, and it took version 7.0.2 over 45 minutes to process.

Granted the result version 7.0.2 produced is notably better, but considering how quick a preview is generated and how much faster version 6.3.3 is, the time version 7.0.2 requires for processing the entire image seems rather ridiculous.

Finally I could upgrade from version 6.3.3 to 7.0.2, but now I have another problem.

When I try to save an image I get this error message: “The model could not load”.

What to do about that? Reinstall for the fifth time?

THE NEXT DAY (240216):
I gave up and reinstalled version 6.3.3. It works very well.
I guess I’ll have to wait for the next upgrade. 7.1, 7.2 or possibly 8.0.

I’d say something is wrong with your computer. I just processed a 241MB Tif file with Giga, and upped it to the max size, and it took 3:14sec to process and write a 3.9GB file.

V 7.0.2 Very slow.

Update 02/16/2024: Speed now acceptable- approx 10-12 seconds.

In 7.01 * **Alpha channel is now enhanced with models instead of being naively upscaled . this caused the twice processing problem in Photoshop:
In standalone Mode,works fine for JPG file, but with transparent background
PNG file, will proocess twice too, one is for Alpha channel. In PS, a file has no
Alpha ,but 7.01 and 7.02 Treat who image as Alpha,thus render the Alpha (entire image)by the Model. This is my guess.

1 Like

But I use the Photoshop Plugin with an flatten Image (no layers, no Alpha), but it’s upscale twice anyway…

Yes, always twice, GAI process the image first,then process the Alpha(this is a bug,Alpha is a full area)

1 Like

I just did some experimenting with this and found that what it’s doing first is flattening the alpha layer into the image, which changes the image layer based on the relative transparency of the alpha. GAI then returns a TIFF with no alpha, and a transformed image.

GAI 6 does not do this. It correctly preserves the Alpha and the Image layers separately.

1 Like

Loss of multiple previews window is a MAJOR downgrade! Multiple models are available. Absolutely needs multiple preview windows to compare side-by-side.


Worst update yet. Rtx 3090, 13900k, 128GB of DDR5 6000MHZ ram. Takes DAYS to process the same amount of files, same resolution I used to do in hours. Not to mention I can not add more than a few thousand files now without the app crashing. In the past I would add 30-40k files worked fine. Now you add more than 6k it blows up. Guess I am going back to RealESRGAN.

1 Like

I don’t know if it’s GAI or XnView MP, but:

  1. I can not use Adobe plugin from XnView.
  2. If I open program GAI from XnView (function open image in GAI) I can not save image because GAI say that can only back image to XnVIew. It’s not work in that way.

Can no longer use Gigapixel. its using all my memory on my Apple mini with 8GB memory. takes forever to load and if I press a setting to change takes ages before I can see its changed. If there is no patch I will have to go back to the previous version which was quick and did a pretty good job.

Can you post a comparison of the noticeably better results from 6.3.3 vs 7.2? As of right now, I have not seen any comparisons between both of them, only seen people talk about performance and bugs. Thanks :slight_smile:

Is anyone else on this forum looking forward to a Comparison View (allowing simultaneous viewing of multiple models) being implemented into the GAI 7 series product?

I valued it and used it as a 1st step to assess which model to use, then I’d switch to a different view (usually Split View, sometimes Side x Side) in the 6.x series and prior. I miss it in GAI 7.

I’m curious re: any thoughts about how you’d use the Comparison View or how it might be presented if it could be re-introduced into this newer product. Thx!


GAI702. When i choose a non-standard size like 1.5x, and perform a batch operation. it randomly starts emitting very small versions of the image. The first few are ok and the rest are tiny - like thumbnails.

Then i have to re-do those over.