Endless problems with Topaz DeNoise for weeks now

I do not have any problems with other Topaz products, only DeNoise. MacBook Pro 2018, OS Monterey v.12.1, everything up to date and just since the release of DeNoise for the M1 Mac have I seen behavior on my machine: Cursor sticks, DeNoise opens up and when I move the image on the screen it 'sticks so I cannot stop moving the picture unless I pull the cursor away from the screen and don’t go back to it, ALSO: the Preview menu does not work, I cannot see a updated preview for any settings, even the Apply button does not work, I know roughly what settings I want and without seeing a preview I to to the file menu to make my choice work by choosing ‘apply’ from the file menu… that is all… the job is done but only by working with this buggy software. Everything is up to date, but what is wrong? DeNoise has never behaved like this before and I’ve removed and re-installed and tried everything I can think of at my end… Does the software need an update? How long will I have to continue to try to work like this?

1 Like

I too am having major problems - in my case with the Mask feature in DeNoise including the “Apply Mask” button does not appear after I use the brush.

I’m having similar issues and only with Denoise AI 3.4.2. It has pretty much made the software useless and it was my go-to noise reduction software. I’ve submitted a detailed message to their new chatbot but they only say it could be days before I get a response. I wonder if I can find an older download of the software and downgrade to the last version that actually worked?

I did get a reply regarding my issue and it is related to the Wacom Pen monitor I use to edit. Seems there is a problem between their rendering interface and Wacom. Word is they are working on a fix. Not sure it applies to these other issues but I am rolling back to v3.3.4

I’m SO HAPPY to have found this – I was going nuts with similar buggy behavior, and was using a Wacom Intuos, up to date on driver. Now I can just put then pen down and open and run DeNoise with the mouse and it works!! Thank you!

You have a driver update for the Wacom? I have the latest version and that is the one that is buggy beyond belief. What version of the driver are you using? I want to. try it. Thanks in advance. I appreciate help with this.

I have driver 6.3.45-2, which I updated before the new computer. It was fine on the old one (Mac Pro a couple of OSs out of date) but now either it or Topaz Denoise is buggy beyond belief with an M1 Pro McBook Pro and OS 12.1. But if I just lay down the pen and use the mouse to invoke and use Denoise, it works fine. I’m happy to do that for now!!

I’m having similar problems including not being able to click on buttons. I am using a Wacom tablet which I thought might be the culprit. It’s funny that I haven’t had the same problems with Sharpen AI. I sent Topaz a message days ago and not a word. I wonder if the realize that professional photographers use their software and need resolutions quicker than 4 days?

One workround I use is to control the app through file menus or key commands. Unfortunately there are commands in the app you can’t control this way.

I suspected that the Wacom tablet might be causing a conflict. I tried hovering over a button with the stylist and clicking with the mouse. That didn’t work. After reading this I put the stylist aside and used the mouse exclusively. That did the trick. Thanks.

I haven’t used a mouse since 1964 and I’m not about to go out and buy a mouse just so I can use Topaz. Anyone who is into graphics uses a Wacom tablet. Topaz is not responding to this problem and it is not a good reflection on a company that is supposed to be helping professionals.

I have a Magic Mouse that came with my previous computer (a Mac Pro). I use the Wacom for 99% of everything I do (Word, Excel, etc) but the scroll capabilities of the mouse sometimes come in handy so I keep it around. I’d have to check back as to how, but I contacted Topaz support yesterday and they got back to me today, but didn’t guess that I was having a problem with a Wacom. I thought it was an installation issue as I had upgraded to an M1 Pro mac. When I told them I had found the problem here, they said they had found several issues with the Wacom driver and they will be fixed in the next Denoise upgrade.

I agree that it would be really nice if that was more readily accessible information. I have been going NUTS trying to figure out what was wrong with a new computer and OS.