Does trial version of AI Clear work?

I watched the recent webinar by Rad Drew and was impressed at the improvements that AI Clear made on his images as first step in his workflow.

I decided to try it out before purchasing, but it does absolutely nothing to the various images I tried. The only thing that does anything are the Clarity and Exposure sliders. The “Recover Details” slider does nothing, and switching from Low to Medium or High Model Strengh does nothing either. Blend mode is normal and opacity at 100%.

I am using large images 3000 pixels wide that contain noise that can be reduced very nicely with the Reduce Noise Adjustment.

Is it possible that the trial AI Clear has a bug?

It seems as though you may be right as this is a test I just did with the PRD version. Maybe you should raise a tech support request from the link above or @JoeFedric-TL can pass it on to development … this is just AI Clear Low, just shows a little change in luminosity.

1 Like

Thanks, @AiDon

@JoeFedric-TL
As mentioned in my first post, using the trial version of AI Clear neither the Model Strength nor the slider for Recover Details has any effect on my images. The Clarity slider works (but I already have another plug-in for that) and the Exposure slider works (but I already have another plug-in for that).

I zoomed into one of my images so you can see the original versus one with Model Strength on High and the Recover Details slider all the way to the right. The 2nd image seems a bit brighter, but in Topaz studio I see no difference in brightness, which is odd.
Original:

Using AI Clear:

Reinstall Studio from the Download Page: https://topazlabs.com/downloads

Try again after a reinstall.

2 Likes

The Low Model doesn’t work well with luminance noise. This image does not have chroma noise, only luma noise, so you’ll want to use Medium or High on this particular image.

@Topacres problem is most likely related to the AI Model files not being properly located, which can be solved with a reinstall.

Re-installing Topaz Studio did the trick! I’m getting great results now with AI Clear!

2 Likes

My apologies, I should have read the v1.11.7 release notes.

Note that the installer doesn’t seem to work if the Install Location is on a drive other than C Drive. There is a message that the previous version wasn’t removed and the install can’t proceed. Files left on disk are:

1 Like

Thanks for noting this, I will bring it up with the team.